Jump to content

Dune 2000 1.06p - Game patching (bug fixes, new features)


Recommended Posts

By the way Funky. You need to check the missions in the "mission launcher + extra missions".

 

The Atreides original campaing A2V1 have a map from the "war of assasins".

 

A2V2 map have 2 black columns in both sides of the map. (H2 and O2 levels too). According to the editor the events in those levels are in a wrong position.

 

H1V1/V2 and O1V1/V2 are surrounded by black, and the events are in wrong places here too (Both A1V1 and A1V2 have the original map, without the black zone)

 

O4V2 have another map instead the original. 

 

I'm assuming the .mis files are ok. I had the "use allocation indexes" to check if the Harkonnen are Harkonnen, and the smuggler base (being Harkonnen) are converted to Harkonnen; didn't find anything wrong.

Link to post
Share on other sites

Tried the latest version, realized the missing resolution change when displaying cutscenes, wanted to post about it...and found your newly implemented option in the config file :D How about a changelog next time? :D :D

 

Oops, might have forgotton to tell about this :D The option didn't seem to work for everyone, so i had to disable it by default just to keep the game highly compatible with the default settings

 

By the way Funky. You need to check the missions in the "mission launcher + extra missions".

 

The Atreides original campaing A2V1 have a map from the "war of assasins".

 

A2V2 map have 2 black columns in both sides of the map. (H2 and O2 levels too). According to the editor the events in those levels are in a wrong position.

 

H1V1/V2 and O1V1/V2 are surrounded by black, and the events are in wrong places here too (Both A1V1 and A1V2 have the original map, without the black zone)

 

O4V2 have another map instead the original. 

 

I'm assuming the .mis files are ok. I had the "use allocation indexes" to check if the Harkonnen are Harkonnen, and the smuggler base (being Harkonnen) are converted to Harkonnen; didn't find anything wrong.

That is weird, I dont even include the original missions in the .zip file, there are only custom missions in it. Did you maybe override the original missions at some point?

Link to post
Share on other sites

That is weird, I dont even include the original missions in the .zip file, there are only custom missions in it. Did you maybe override the original missions at some point?

 

You are right. The mission launcher includes .ini files for the original maps, so I assumed the .map files were there too. 

 

Those custom maps sure was my fault. Sorry for not noticing better.

Link to post
Share on other sites
  • 3 weeks later...

i just checked out whats up with that uinew.bmp and found out that the game is able skip using its special formats and uses more standard stuff instead, maybe that could be interesting for some modders, dunno ... is there any file you guys have no clue what it does? or you dont know how to modify/mod it?

 

here is a small list of what i found (there is much more...) first you see the file name the game is using normally and afterwards the alternative it can load:

;Colours.bin -> colours.txt

;vars.bin -> vars.dat

;font.bin -> font.map

;font.fnt -> font.bmp

;mouse.r16/mouse.r8 -> mouse48.bmp

;circles.bin -> SCircles.bmp

;templates.bin -> many different .bmp files...

....

 

 

if you like to test around, the bool to change the formats is here:

0x004EB014, DisableDebugFileFormats

vars.bin -> vars.dat - this bin file need to editing in some program. Thera are include vars for damaged ground and it need to testing with new tile set (ise, volcanoes).

circles.bin -> SCircles.bmp - need

many different .bmp files.. - do you have full list of bin files with short description? Perhaps some bin don't know and they will helpful.

Link to post
Share on other sites

vars.bin was the only file tibed could not edit, I already made it all adjustable via rules.ini and map .ini files

Maybe you meant tiledata.bin and tileatrX.bin?

 

rules.ini is here: http://funkyfr3sh.cncnet.org/files/d2k/rules.ini

a lot of map .ini files can found via cncnet, start it up once and it will download a lot of fan made mod maps, co-op missions and more

 

this file loads SCircles.bmp and afterwards converts it to circles.bin, so make sure you make a backup of the original circles.bin before you start it.

From the looks of it the file is loaded directly from the Data folder rather than Data/bin, so place your SCircles.bmp in there

 

http://funkyfr3sh.cncnet.org/files/temp/dune2000-circles.exe

 

Note: you have to figure out the size of the SCircles.bmp file, the only thing I can tell right now is that you need a 8bit bmp file and the circles graphic is only loaded once the gameplay starts (not used in the main menu)

Link to post
Share on other sites

Thank you, FunkyFr3sh,

I consider the information and files. Then we'll see. The purpose of this question was originally this problem:

Preconditions:

- i created special new BLOXICE.RAR - wanted to create only ice tileset and i made it for test.
- in this ice tileset I replacet base ground tales to ice ground

Aktual result:

- ice gound displayed in game, can place buildings on it
- but when the building was destroyd - ice ground automatticaly changed to standart brown ground only in that area, where the building was. Other ground is ice (white)

100% i was replaced all ground tiles for tileset, but after destroing buildings i see brown ))) Unfortunately i don't have this tile set (in other laptop fot 2 month). I'll upload CnCnet certeinly. Probably will apply mod for cnc in final.

Link to post
Share on other sites

Hi, guys,
You all did a great job and making me happy!! ))

Preconditions: (for 2 issues):

OS: Windows7
Screen resolution: 1600x900
Game resolution: 800x600

1. clean 1.02 dune 2000 (no cd)
2. patch to 1.06 (cd)
3. crack to NO CD
4. copy "win-builds-for-cnc-patch" folder to game directory and run "win-install.bat" (success)
5. download "dune2000.exe", "Dune2000Config.exe" from here: http://forum.dune2k.com/topic/26661-new-patching-framework/
and added files to the game.
6. copy "dune2k-master" folder to game directory and run "build.cmd"
7. run "Dune2000Config.exe" with video params: https://drive.google.com/file/d/0B3sIFwvou1uQclpUTFlaRFMweWc/view?usp=sharing

- tested with dxwnd or not (no matter how)
8. replaced files from my mod: BLOXBGBS.R8, R16, other additional tilesets, all bin files, SOUND.RS, maps, _PRAC.MIS, text.uib, DATA.R8, R16.

Issue 1:

Some graphic artifacts in gui (reproduce only in 8bit per pixel): https://drive.google.com/file/d/0B3sIFwvou1uQUlQwQUJYNncyTFk/view?usp=sharing

Issue 2:

Build Queues Patch bug maybe. How to reproduce:
 

When I spaming units from all buildings whith big queues (fom 20) sometimes the unit construction stops. I have to add more queues for construction, but the queue was already set > 10
Maybe it's in my mod only? Creating 7 units from 5 buildings at the same time:

Example:
 
- ORDOS BARRACKS (TROOPER) - queue 15 in production
- ORDOS HEAVY FACTORY (ORDOS COMBAT TANK) - queue 25 and no  construction
- ORDOS LIGHT FACTORY (QUAD) - queue 37 in production
- ORDOS HIGH TECH FACTORY (RAIDER + CARRYALL) - queue 40 no  construction + queue 10 in production
- ORDOS PALACE (NEW ORDOS HEAVY TANK + SABOTEUR) - queue 17 in production

Then after 1 minute or more some production units stoped and for dome starting constraction.
 
All units with queues, except Saboteur. It is possible to fix?
Link to post
Share on other sites

I guess it is probably in data.r16, give that one a try

However, I cannot add support for custom data.r16 files in my patch, so you wont be able to play the normal tilesets anymore when you change this file

Data.R16 doesn't contain ground graph (cheсked). Normal tilesets no need to changing.

Possibly to add new tilesets in game. Write In "Dune2000.exe" you can write "..NEWBGBS.....R8", "......R16" and write map names assigned whith it. For BLOXXMAS westwood did that and some others except BLOXBGBS. Then need to add R files with new tilesetes and write maps in TEXT.UIB.

Link to post
Share on other sites

The source code on github is outdated not maintained anymore, there is not really much use for it anymore

Build queues patch is using a older version of my patch, it does not have 8bit support and that's why you have the graphical glitches in the sidebar

 

Dune2000Config has a lot of new options not supported by these old versions, so it won't work properly with those. You will have to use the dune2000.exe linked here in the first thread to gain all new features including cncnet multiplayer

 

Build queues is not made by me so I cannot help you with anything related to it :)

 

Dato created a new tileset, it is pretty easy, all you need to do is to modify the .mis file. You can do that with a hex editor or even better use the latest D2k map and mission editor. A tile set is made out of the .r16/.r8 files and a matching tileatrX.bin file. But there are also a few things in other files sadly, that make it hard to have a 100% perfect new tileset. There is no need to modify the dune2000.exe or text.uib (at least not in skirmish / multiplayer)

  • Upvote 1
Link to post
Share on other sites

"to modify the .mis file" - this is for misssins only or fo skirmish lan to? Im not using hex editor unfortunately. Can you prompt how to create tileset for using in skirmish/lan without editing .exe?

dato made a few, you can find some examples on cncnet (I think he added "RA Graphics" to the name of the maps)

Link to post
Share on other sites
  • 4 weeks later...

A lot of people seem to have problems running the game on windows 10 so I tried to do some changes to prevent windows from setting any weird compat modes automatically. Now i'm looking for some tester to ensure the latest version is still working for everyone.

 

Please post your operation system in here, mainly looking for Vista/7/8/10 users

http://funkyfr3sh.cncnet.org/files/temp/dune2000.exe

Link to post
Share on other sites

I would like to write about another little bug in Dune 2000. Music volume. Perhaps it is possible to fix this.

I prefer play without music. If to make music volume to 0 and switch to Windows (Alt-Tab) for a long time (more than a minute, I suppose), then (if I back to Dune2000) music becomes loud.

 

So I must again to go to menu and to change slider position. The slider position of music volume stays the same (minimal). So I must first increase volume and after decrease it to 0 again.

 

I don't know exactly, how much of time must spent when volume changes.

 

I noticed this before, but totally forgot about it. Gonna check it out soon

Just remaining.

It will be not bad, if you would like to find a way to fix the bug with music volume.

Good idea with alliances in multiplayer game. I like it.

I even try to press "A" in missions :-) . Of course, it does not work there.

Link to post
Share on other sites

Thanks for testing, Gruntlord has exactly the same problem. This information is really useful, now we at least have an idea of what is going on

 

I'm having the same problem here: ""This video card does not support the required modes..." when i'm trying to launch the game.

I'm using the last "dune2000.exe" version on Windows 10 build 10240 rtm

I've read on the forum there's a workaround for this by changing the game folder's name. I tried it and it worked, but only one time. As soon as I started another game, same error shows up. I'm using the game in "Win 8 compatibility mode" for now, but this gives me freeze problems on LAN games... I'll still using it 'til a solution come up.

Link to post
Share on other sites

Sorry to intervene but please fellows put a little effort to install a couple more OSs (whatever is working in your hardware). HDDs are huge nowadays. We cannot have everything in life and the same applies in software (and hardware). BTW a couple of hours ago I had my first 'contact' with Windows 10 at a local store... Horrible experience. I am not going to install this crap till an app/game doesn't work on anything else.

Link to post
Share on other sites

HI guys, firstly to thank you all for your tremendous work on modding the game which i have loved for years, its fanastic to see others who love it just as much as me after all this time still!

 

Im writing to see if I can have a little support because im having using the build Q mod (modified dune2000.exe) and the dune2000config.exe.

My system details, ubuntu 15.04 on acer c720, intel i3 cpu, intel built in gpu hd4400, 4gb ram, 120 gb sata3 ssd.

 

Using play on linux i can play this game as you would expect it to run on windows and it works fine. I can use the mission select mod fine, i can use the old high res patch 1.41 to play at 1366x768 (my max resolution). Everything works fine there.

 

When I try to use the dune2000config.exe to use some of the options with in there no changes are made to game at all and the dune2000.ini file is created but as i say it makes no difference, the old hisres 1.41 does work though.

When I use the buildqueue modified dune2000.exe it completely crashes play on linux and the game wont launch and i only get a black screen. replacing the modified exe with the original exe fixes it again.

 

I have used both these mods succesfully on another pc which runs windows 7 natively so i know they work but i was hoping someone might some ideas on getting these 2 mods to work on play on linux?

  • Upvote 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...