Jump to content

Dune2K - High Resolution


Recommended Posts

Thanks for the wonderful patches, N.KindtD2k Sardaukar!

 

To D2k Sardaukar:

However, I have a problem. The game is fully playable, but there are some issues with menu, campaign interface and so on. I've read the whole topic, but could not find the solution. I feel like I missed something. Could you please help me?

I am using fresh 1.06 UK game and version 1.3.1 of your patch. See screenshot and patched/non-patched files in the attachments for the details.

 

Also I might be able to help with compiling python script into the single executable. I see that you are using Python 3.3. Which tool you are using for packaging currently?

I just noticed your post. Thank you for bug-reporting.

 

Another user also seems to have this problem and I think it's because the .uil files are not patched. The question is why this is not happening and why there is no error message. A wild guess is that for the UK version (if that is a different version as ENG??) the uil files are actually with capitals letters so it's .UIL file instead of .uil. I posted a new version, please try that one and we will see again.

 

I'm using Python 3.3 with cxfreeze. If you got an idea to make it one single executable, please share.

 

@Sardaukar: Made an update to check for data integrity and size. If you want you can use this one by passing --test_checksum switch. The patch will only check for the data and return. Return code is -5 on failure which you can use to warn people that it might not work out because of size/checksum mismatch but they can still try to (i.e. changes from previous patch). Checksum is taken from vanilla 1.06 ENG version.

 

p.s. Currently reinstalling Windows and don't have MSVC at hand. This one is compiled with GCC 4.7.1 (-march=i386 -Os -s). File size is bigger but it won't need MSVC redistributables any longer (i.e. can be used on a freshly installed XP without problems).

 

p.s. The filename of the patch must not contain any '-' (minus) due to how GCC works internally with commandlines.

Nice. I put it into the new version

 

New version, click my signature.

Version 1.3.2	1) Fixed bug in script auto-add-sand for small maps.	2) Changed sand in auto-add-sand to black unreachable area.	3) Updated N.Kindt's .DAT patcher, this gives:		a) Check for data integrity and size of .dat file to warn users.	4) Updated readme to make clear only English version of Dune 2000 is supported.	5) Updated .uil patcher to include files with capital letters.
  • Upvote 1
Link to post
Share on other sites

Still giving an error, even with a DAT file from the 1.06 patch 

EDIT: The game works fine though.

Edited by Shai-Gel98
Link to post
Share on other sites

version 1.32 cannot patch it. the error is below

1280x1024Working on AACCT.TGAWorking on CREDITS.TGAWorking on DUNEMAP.TGAWorking on DUNEMAP2.TGAWorking on HACCT.TGAWorking on HOUSE_SE.TGAWorking on MULTIUI.TGAWorking on OACCT.TGAWorking on PICTBOOK.TGAWorking on SCOREMP.TGAWorking on SCOREUI.TGAWorking on WOLLOBY.TGAWorking on WOLLOB.TGAWorking on Title.TGAWorking on .uil filesTraceback (most recent call last):  File "C:\Python33\lib\site-packages\cx_Freeze\initscripts\Console3.py", line 27, in <module>  File "d2k_patch.py", line 66, in <module>  File "d2k_UIL_fix.py", line 115, in funcTypeError: sequence item 1: expected str instance, list found

 

Link to post
Share on other sites

 

I just noticed your post. Thank you for bug-reporting.

 

Another user also seems to have this problem and I think it's because the .uil files are not patched. The question is why this is not happening and why there is no error message. A wild guess is that for the UK version (if that is a different version as ENG??) the uil files are actually with capitals letters so it's .UIL file instead of .uil. I posted a new version, please try that one and we will see again.

 

I'm using Python 3.3 with cxfreeze. If you got an idea to make it one single executable, please share.

 

Nice. I put it into the new version

 

New version, click my signature.

Version 1.3.2	1) Fixed bug in script auto-add-sand for small maps.	2) Changed sand in auto-add-sand to black unreachable area.	3) Updated N.Kindt's .DAT patcher, this gives:		a) Check for data integrity and size of .dat file to warn users.	4) Updated readme to make clear only English version of Dune 2000 is supported.	5) Updated .uil patcher to include files with capital letters.

Is 1.3.2 supposed to be the final version?

Link to post
Share on other sites

Still giving an error, even with a DAT file from the 1.06 patch 

EDIT: The game works fine though.

The checksum is for DUNE2000.dat from 1.06 US patch (http://dune2k.com/Duniverse/Games/Dune2000/Downloads/Patches).

If you get a warning you can still go on. The checksum test is built in just to give a warning since the readme recommends to patch over a fresh install and this is what the checksum test ensures. If you however install D2K and patch it with 1.06 US (d2k106us.exe) you should have no problem with the checksum. If you have a checksum mismatch then all bets are off, it might work ok and it might not. With a passed checksum test you have a guarantee that it will definitely work.

 

 

Is 1.3.2 supposed to be the final version?

Guess so. I was waiting for the tile fix from Sardaukar and both his script and my patch are now complete as far as i can tell.

Link to post
Share on other sites

New version, click my signature.

Thank you for quick bugfix.

Unfortunately, new version is unable to patch .uil files. I am getting the same error as wxg2004.

Also, I've uploaded all files that being affected in the patching process. I kept the directory tree structure, so you can use it for patch testing. Please refer to the folder "original" in the attachment to my previous post.

 

I'm using Python 3.3 with cxfreeze. If you got an idea to make it one single executable, please share.

Unfortunately, there is no simple way to pack Python 3.x script into the single PE executable. Especially with cx_Freeze. Of course, you always can downgrade to Python 2.x and use PyInstaller or py2exe.

By the way, why is your patch requires elevation? The user will be forced to open a new elevated command prompt window to see the error message, if any.

Link to post
Share on other sites

I think you should download this English patched version that also has mission select mod and try to hi-res patch it, it should work.

Thank you for the link, it works now with 1920*1080 (even the videos).

When trying to play at 2560*1440, the game crashes: After video and mission briefing I get a black screen and nothing happens. Using ALT+TAB I can see a second application "SetTImageToResource".

This happened to with the maps I tested.

 

EDIT: replaced all the language files, added ui_GER.r8 and ui_GER.r16, now this error only occures for some of the maps (e.g. H8V2)

others are fine: see picture

the upgrade-button is missing (same with starport), can't find them by clicking around.

post-52478-0-62361300-1369250552_thumb.p

Link to post
Share on other sites

Thank you for quick bugfix.

Unfortunately, new version is unable to patch .uil files. I am getting the same error as wxg2004.

Also, I've uploaded all files that being affected in the patching process. I kept the directory tree structure, so you can use it for patch testing. Please refer to the folder "original" in the attachment to my previous post.

 

Unfortunately, there is no simple way to pack Python 3.x script into the single PE executable. Especially with cx_Freeze. Of course, you always can downgrade to Python 2.x and use PyInstaller or py2exe.

By the way, why is your patch requires elevation? The user will be forced to open a new elevated command prompt window to see the error message, if any.

 

I don't know how much work it is to downgrade to Python 2.x.

 

What do you mean with new elevated command prompt window? When I run my cxfreeze generated .exe file it does that in administration mode and give all print info (and also errors) in the first command prompt window it starts in.

 

The file you attached does not contain the .uil files that are causing the problem. I find the error also rather strange, because all .uil files should be the same unless you got some different kind of version? Could you upload your .uil files? They are located in data/UI_DATA. I want to see if something is different and test my script directly on them.

 

Thank you for the link, it works now with 1920*1080 (even the videos).

When trying to play at 2560*1440, the game crashes: After video and mission briefing I get a black screen and nothing happens. Using ALT+TAB I can see a second application "SetTImageToResource".

This happened to with the maps I tested.

 

EDIT: replaced all the language files, added ui_GER.r8 and ui_GER.r16, now this error only occures for some of the maps (e.g. H8V2)

others are fine: see picture

the upgrade-button is missing (same with starport), can't find them by clicking around.

You can't add ui_GER.r16 after the patching, it contains the button images and location information that need to be updated. I'm suggesting you try English Dune 2000, because I can't guarantee if all the needed files are correctly patched for german version. If you insist on it you can try to rename ui_GER.r16 to "UI_ENG.R16" (with these capital letters!), run the patch again (see it's patched in console screen) and if needed rename back to "UI_GER.R16".

 

There is no H8V2, it does not exist, starting this mission gives a crash.

 

@wxg2004: I'm looking into the error.

Link to post
Share on other sites

I don't know how much work it is to downgrade to Python 2.x.

Well, if you interested, I can help you with that. First of all, You need to add import line

from __future__ import print_function
to all source files of your patch.

You also need to install LZMA support (I suppose you are using lzma module because there is a _lzma.pyd file that comes with your patch) and pywin32 packages for Python 2.7.

Then if there are any problems, please share.

When patch is gonna be working, you need to download PyInstaller and simply run pyinstaller --onefile patch.py.

 

What do you mean with new elevated command prompt window? When I run my cxfreeze generated .exe file it does that in administration mode and give all print info (and also errors) in the first command prompt window it starts in.

Please see screenshot in the attachment. I've opened the first console window, launched your .exe, it asked me for administrative privilegies and opened a new elevated command prompt window. If I opened the first window in the administrator mode, the new window would not be created.

 

Could you upload your .uil files? They are located in data/UI_DATA. I want to see if something is different and test my script directly on them.

Done.

post-52612-0-41771000-1369262333_thumb.p

uil.zip

Link to post
Share on other sites

Hello mates. I have a serious problem with the hires patch. I have the fresh instalatin (try US and UK patch 1.06 - same result)

While patching "title.tga"  the patching window dissapear with some king of error maybe (can´t pause the window)

Use 3 different computers everyone using windowsXP, same result again. The game starts to the menu bud looks like "Refaim" wrote on the site 21. Anyway the game is not working correctly, resolution is not working, singlepayer too :(   Can anyone give some hint plz? 

 

from what i see here, the screenshots of those the game working looks excellent. Nice work really. Hope ill be able to fix my problem soon to play it in hires too :p

 

thank u very much for help

Link to post
Share on other sites

Well, if you interested, I can help you with that. First of all, You need to add import line

from __future__ import print_function
to all source files of your patch.

You also need to install LZMA support (I suppose you are using lzma module because there is a _lzma.pyd file that comes with your patch) and pywin32 packages for Python 2.7.

Then if there are any problems, please share.

When patch is gonna be working, you need to download PyInstaller and simply run pyinstaller --onefile patch.py.

 

Please see screenshot in the attachment. I've opened the first console window, launched your .exe, it asked me for administrative privilegies and opened a new elevated command prompt window. If I opened the first window in the administrator mode, the new window would not be created.

 

Done.

 

Thank you, I made the script into one exe. It went rather smooth from Python 33 to Python 27. Only one function rewritten (was bad written anyway) and one except error was not recognised.

 

I think I fixed the bug in patching the .uil files, please try version 1.3.3. Download link at my signature.

 

I was not capable of fixing the elevated command prompt, I don't know how to control it. Do you perhaps have an idea?

 

Finally I foud my dune2000 is a mod verion.sorry! I download an other one.1.31 work well! thanks!

Ah, nice that it's working now. :)

 

Hello mates. I have a serious problem with the hires patch. I have the fresh instalatin (try US and UK patch 1.06 - same result)

While patching "title.tga"  the patching window dissapear with some king of error maybe (can´t pause the window)

Use 3 different computers everyone using windowsXP, same result again. The game starts to the menu bud looks like "Refaim" wrote on the site 21. Anyway the game is not working correctly, resolution is not working, singlepayer too :(   Can anyone give some hint plz? 

 

from what i see here, the screenshots of those the game working looks excellent. Nice work really. Hope ill be able to fix my problem soon to play it in hires too :P

 

thank u very much for help

Perhaps version 1.3.3 works for you, download link in my signature, if not, I suggest to get the Gruntlord's edition.

  • Upvote 1
Link to post
Share on other sites

Hello hello :p   Problem resolved the game is working perfectly in Hi-res, but i´m little bit confused.....

I read almost all the topics here and try to do one thing told here.

The only thing i´ve done was to place "mission" folder  in to the game directory from the CD.

 

Question: why i don´t have the mission folder after install on my hdd? I really have the original english version of the game, but the mission folder is only on the CD. That´s why the patcher did not finished patching....  strange because anyone of u maybe with the english version dont have the same problem as i had.

 

Question 2: i wonder why is this working becouse after copying the Mission folder in to game directory i didnt do anything else.

I wonder because i didnt change any  path...  and the game knows  to use the  updated mission folder on the directory insted of use the one from the CD. I really thing that this cant work. (but its working) :)

 

Question 3: do u planned to support another resolutions? i have on the main computer at home 1360x768 or something like that im not sure if i have 16:9 or 16:10 . Can i hope for those in the future? :))))

 

anyway thanx for your time and help im happy that this fine classic working in hires now. Great job

Link to post
Share on other sites

Hello hello :P   Problem resolved the game is working perfectly in Hi-res, but i´m little bit confused.....

I read almost all the topics here and try to do one thing told here.

The only thing i´ve done was to place "mission" folder  in to the game directory from the CD.

 

Question: why i don´t have the mission folder after install on my hdd? I really have the original english version of the game, but the mission folder is only on the CD. That´s why the patcher did not finished patching....  strange because anyone of u maybe with the english version dont have the same problem as i had.

 

Question 2: i wonder why is this working becouse after copying the Mission folder in to game directory i didnt do anything else.

I wonder because i didnt change any  path...  and the game knows  to use the  updated mission folder on the directory insted of use the one from the CD. I really thing that this cant work. (but its working) :)

 

Question 3: do u planned to support another resolutions? i have on the main computer at home 1360x768 or something like that im not sure if i have 16:9 or 16:10 . Can i hope for those in the future? :))))

 

anyway thanx for your time and help im happy that this fine classic working in hires now. Great job

1) I'm not sure why the game does not copy the mission folder to the HDD, but I'm guessing it's a simple form of anti-copying.

 

2) The game probably checks first the main Dun2000 folder, if the missions aren't there, it checks the CD.

 

3) My script checks which resolutions your PC can display and than removes the ones that aren't supported by Dune 2000. The 'game area' or viewport uses tiles with a width of 32, in your resolution 1360 won't fit complete tiles, there is half a tile left. This half tile gets displayed on the next row and gives the disordered viewport. I'm still looking for a simple solution, the current ideas I got require some real dune2000.dat hacking which I'm not that good at (N.Kindt is the specialist in this).

Link to post
Share on other sites

I was able to edit the dune2000.dat file to ignore the restriction that a map width has to be even. This fixed the tileset bug partly for some resolutions. It was fun that I was able to find and really hack this, but I'm not sure if I can turn this into a working thing. The fog-of-war is still buggy and I had to disable a map error function and I have no idea what it's for.

 

Proof with 1360x1024:

 

555sn5.jpg

 

edit: I got it working without editing the width check and even correct fog, but there is sometimes a small misalignment when moving across the map. Not sure what is causing it.

 

I think only maps that fit tiles of size 16 (width) can work with this cheap hack. 1366x768 also works.

Edited by D2k Sardaukar
  • Upvote 1
Link to post
Share on other sites

If you use a CD the dune2000.cfg file is configured to read from the CD. You must edit that so it'll read from th HDD. There are some topics about how to do this, search the forum.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...