Jump to content
dynasty

Dune Dynasty

Recommended Posts

Dynasty, I don't mean the button is not click-able, I meant that Mentat's face is not click-able when on the Mentat screen.  Maybe I'm doing something wrong?

I already figured out the skip trick, however was using the options menu and double clicking Music on/off button :P

 

I am aware of how BBcodes work, they were present in my signature at one point but for some reason are now missing. I care little anyway as it was only a display for my current halo sessions for which there is no longer any need.  I don't play the game any more and care little about sharing my stats :P

With regards to the music, I've been playing all night last night (massive headache now), and noticed that dune2000 music does indeed get its fair share of play time, once enabled correctly :P
(my bad)

The way i noticed the movement issue was with a siege tank and a combat tank, before entered the same tile to squish a trooper and then stopped there.
the unit underneath seemed to be protected by damage, but once both units moved again they went their separate ways.

 

Normally I'm shit hot on grammar and punctuation and things, but honestly towards the end of the day when I'm tired and stoned grammar sort of goes out of the window in favour of speed typing :P

 

Share this post


Link to post
Share on other sites

Oh, du bist ja ein Grammatik-Polizeimeister, ja? ;)

Hast du da Probleme mit? :P

Normally I'm shit hot on grammar and punctuation and things, but honestly towards the end of the day when I'm tired and stoned grammar sort of goes out of the window in favour of speed typing :P

Sorry. I've been hanging out in a writers community lately. It seems I can't read anything without subconsciously picking out the errors :P

Share this post


Link to post
Share on other sites

Hast du da Probleme mit? :P

Sorry. I've been hanging out in a writers community lately. It seems I can't read anything without subconsciously picking out the errors :P

Haha, that's okay dude, honestly I've noticed myself making that mistake quite frequently these days, it even bothers me xD

Share this post


Link to post
Share on other sites

Hast du da Probleme mit? :P

Aber nein, mein Herr! ;)

Normally I'm shit hot on grammar and punctuation and things, but honestly towards the end of the day when I'm tired and stoned grammar sort of goes out of the window in favour of speed typing :P

That's quite familiar to me :) Actually, I just remembered there's a phrase for that, which I picked from the Urban Dictionary: insomnia dyslexia

BTW, what really interests me in this respect is that most of the typos people make aren't random. I mean, it's not the slip of the finger when you type an adjacent letter on the keyboard, or type the letetrs* in a wrong sequence, or stuff like that. Sure, those typos happen too, but many more are quite meaningful - for example, one might type a homophone of the intended word, like "bare with me" ~ "bear with me" (it's a real example, I just don't remember where I read that, as I don't keep track of those; maybe I should), etc. I fancy this type of a mistake isn't only rather frequent (dunno if anyone ever did some statistical analysis but it would've been great if someone did) but is also quite telling of how our handling of spelling (writing, typing) stuff works in general.

* I kept it as a kind of self-demonstrating thing, since it's an actual typo I made.

Share this post


Link to post
Share on other sites

I think I've read something about that actually, sometimes when I make a typo its not only the wrong spelling or wrong word, in the example of 'bear with me / bare with me', but completely different word that wouldn't even fit in the sentence, it might be something else I was thinking about or doing at the same time.

anyway, moving on.

So I've been playing again tonight and had worked my way up to level 9 on the Ordos campaign, was doing quite well and then.... bam

 

The crash occurred when I clicked on the rocket turret icon to begin construction, I had noticed prior that I'd hit some kind of building/unit cap.

Wasn't sure what exactly caused the crash, but I did have a number of units queued on the starport (purchased, but hadn't clicked send order) that I was planning on breaking the unit cap with :P

Maybe that was a bad idea?

Share this post


Link to post
Share on other sites

Maybe max structures index cap (STRUCTURE_INDEX_MAX_SOFT, that it's first limit structures index) was increased but the function:

 

Structure *Structure_Get_ByIndex(uint16 index)

{

    assert(index < STRUCTURE_INDEX_MAX_HARD);

    return &g_structureArray[index];

}

 

didn't manage the second limit: STRUCTURE_INDEX_MAX_HARD.

 

In original game limits structures are set so:

 

enum {

    STRUCTURE_INDEX_MAX_SOFT = 79,                          /*!< The highest possible index for normal Structure. */

    STRUCTURE_INDEX_MAX_HARD = 82,                          /*!< The highest possible index for any Structure. */

    STRUCTURE_INDEX_WALL     = 79,                          /*!< All walls are are put under index 79. */

    STRUCTURE_INDEX_SLAB_2x2 = 80,                          /*!< All 2x2 slabs are put under index 80. */

    STRUCTURE_INDEX_SLAB_1x1 = 81,                          /*!< All 1x1 slabs are put under index 81. */

    STRUCTURE_INDEX_INVALID  = 0xFFFF

};

Indexes 79, 80, 81 are reserved respectively for all Walls, 2x2 and 1x1 Concrete Slabs.

Share this post


Link to post
Share on other sites

The mentat's face is clickable for me.
He should blink or move his lips when you poke him.
 
I haven't been able to reproduce the crash either. 
I haven't increased the structure or unit limits, only the scenario limit.
It should also be okay to queue units in the starport but not purchase.

It's probably some weird memory error or a translation error.
I'll probably add in some more error checking in the future, which will hopefully locate the cause.

Share this post


Link to post
Share on other sites

Release notes from version 1.5.6:

  • Fix crash due to scenarios incorrectly using "MaxUnits" when it should be "MaxUnit" (e.g. Stefan Hendriks' Atreides Campaign).
  • Implemented true (timer-based) game speed adjustment option.  Enabling this will fix game-speed-dependent bugs in the original game such as the sonic blast range and the launcher's inaccuracy.
  • Fix error sound being played continuously when an AI cannot release a saboteur.
  • Launch deathhand missiles from the centre of the selected palace.
  • In skirmish mode, fix walls being revealed to the player.

Share this post


Link to post
Share on other sites

List of detected bugs since v 1.5.5 (remain in v1.5.6):

 

- Units Sight stat is applied only when: a) unit stops; b) unit is given a new waypoint. Makes scouting a too manual and tedious process.

- Harvesters are being reset every time they exit the Refinery (as if they were recently built or brought with new refinery), results in harvesters staying idle if no spice field is found in close proximity (very annoying since player needs to constantly check the unloaded harvesters and manually send them). This occurs in about 80% of cases, not sure exactly what causes it since sometimes in rare cases carryalls do return harvester back to the field it came from.

- Related to the last issue: Manually sent harvesters don't use carryalls (if any available) when the destination spice field is far away. Possible cause: at the exact moment a harvester is unloaded there are no carryalls available (though I saw it occur even with carryalls 100% available). Possible solution: Create a carryall queue for harvesters and damaged units and make carryalls check the queue (with default priority set to harvesters).

 

And again, thanks for the great job done!

Share this post


Link to post
Share on other sites

List of detected bugs since v 1.5.5 (remain in v1.5.6):

- Units Sight stat is applied only when: a) unit stops; b) unit is given a new waypoint. Makes scouting a too manual and tedious process.

- Harvesters are being reset every time they exit the Refinery (as if they were recently built or brought with new refinery), results in harvesters staying idle if no spice field is found in close proximity (very annoying since player needs to constantly check the unloaded harvesters and manually send them). This occurs in about 80% of cases, not sure exactly what causes it since sometimes in rare cases carryalls do return harvester back to the field it came from.

To the best of my knowledge, both issues just reflect original game behaviour, except for the fact that when the player has carryalls, they must automatically ferry harvesters between a spice field and a refinery until the spice field is depleted, in which case the player must manually assign the harvester to another field.

Share this post


Link to post
Share on other sites

Yeah, doesn't seem abnormal to me. Though it'd be nice to have auto-reveal on every cell a unit passes, I'd leave it as extra option even if it's implemented.

 

As MrFlibble said, the harvester not being brought back usually means the current field it was harvesting is depleted.

Share this post


Link to post
Share on other sites

Not sure what changed, but this latest version seems to run much smoother on my Mac.  Great work!

Share this post


Link to post
Share on other sites

Dune Dynasty doesn't seem to be compatible at all with the Spanish and Italian language files from Dune II v1.07 English/Italian/Spanish. Whenever I try to force the .cfg file to load either the Spanish .GER files or the Italian .FRE files of this version, the program gives the same fatal error at boot. :/

 

I hope these could added to subsequent releases. Since these languages are stored in files which have the very same extensions as French and German, I suppose they would have to be implemented by detecting and accepting the reworked version of these files, something which is not possible now in the current version.

Share this post


Link to post
Share on other sites

I doubt he can make it compatible without actually getting the files, you know...

Share this post


Link to post
Share on other sites

Thanks.  Found the problem with the Spanish version:

 
For whatever reason, only the English version of Dune II actually
displays the sandworm hint.  The German version didn't even bother to
translate it, and the Spanish version decided to cut it out
altogether.  I reworked the string system slightly for custom
campaigns, and the missing string broke something.
 
(The accented characters problem you described in the other thread has
been fixed in OpenDUNE for a while now.)  
 
 
The two Italian versions work for me.  The fan Italian version is
missing english.pak, and the game may or may not produce an error
message, but otherwise it works (using "English").
Not sure if that fixes your problem.

Share this post


Link to post
Share on other sites

Thanks.  Found the problem with the Spanish version:

 

For whatever reason, only the English version of Dune II actually

displays the sandworm hint.  The German version didn't even bother to

translate it, and the Spanish version decided to cut it out

altogether.  I reworked the string system slightly for custom

campaigns, and the missing string broke something.

So what should I do to avoid this issue? Are you going to release an update, or could I do something myself?

 

(The accented characters problem you described in the other thread has

been fixed in OpenDUNE for a while now.)

Really? But I'm using the last version, which is 0.7, and this one has the problem with not displaying the accented characters at all, at least in Spanish.

They don't seem to have released anything beyond version 0.7, or am I wrong? It's almost two years since that release was done and maybe they just moved somewhere else and put it there, but in the official OpenDUNE site there's not anything beyond version 0.7 for sure.

 

The two Italian versions work for me.  The fan Italian version is

missing english.pak, and the game may or may not produce an error

message, but otherwise it works (using "English").

Not sure if that fixes your problem.

I actually don't use the fan Italian version at all, since I'm not Italian. I'm actually interested in solving the problem with v1.07 English/Italian/Spanish displaying Spanish language.

Share this post


Link to post
Share on other sites

There is a "pre v0.8" release about OpenDune:
https://github.com/OpenDUNE/OpenDUNE

(go to Download ZIP on right-bottom)

 

This one fixes several issues respect v0.7.

To open the project you should have Visual Studio 2010 and then "compiling" the solution to obtain the .exe game.

Share this post


Link to post
Share on other sites

OK, I tested the pre v0.8 OpenDUNE thanks to drnovice. I know this is thread is for Dune Dynasty and not OpenDUNE, but since this has been brought up already, I'll give some impressions.

It's true that the pre v0.8 fixes the problem with the accented characters, but unfortunately it adds an additional issue that was not present in v0.7 at all. The Spanish text in both the intro and mentat briefings/hints is displayed in the wrong order. The intro plays each line in the inmediately previous position that they should, because the line "present" after the Virgin logo is skipped and replaced with "The Battle of Arrakis" from the title screen, and then the text sequence goes on that way. The mentat briefing/hints are even worse, with their lines being randomly scattered in places where they shouldn't be displayed, not to mention that the house selection scenes display some "win text." and "Test sceneario win text" lines.

Everything else seems to be fine.

I noticed this is only happening in Spanish. Both English and Italian seem to be perfectly fine. Out of luck, then. :(

Share this post


Link to post
Share on other sites

The OpenDUNE weirdness is just the same missing sandworm string issue in a different form.  Should be fixed in OpenDUNE now.

Share this post


Link to post
Share on other sites

Hey Dynasty!

Can you show us what is the "missing sandworm string issue"?

I saw into source code:

                if (g_config.language == LANGUAGE_ENGLISH) {                    GUI_DisplayHint(STR_WARNING_SANDWORMS_SHAIHULUD_ROAM_DUNE_DEVOURING_ANYTHING_ON_THE_SAND, 105);                }

Is this?

Share this post


Link to post
Share on other sites

Release notes from version 1.5.7:

  • Fix crash on startup when by using Spanish data files.
  • Put nouns before adjectives for Italian and Spanish.
  • Use English audio for Italian and Spanish.

 

Hey Dynasty!
Can you show us what is the "missing sandworm string issue"?


The string for STR_WARNING_SANDWORMS_SHAIHULUD_ROAM_DUNE_DEVOURING_ANYTHING_ON_THE_SAND
is simply missing in the Spanish version's MESSAGE file. Normally
there are 28 non-empty strings in the MESSAGE file, but the Spanish
version only has 27 non-empty strings. OpenDUNE made some changes to
the string loading, which meant that all strings that are loaded after
this one are off by one index.

(As you can see in the code posted, the hint is only shown for English.
Who knows why they decided to do that.)

Share this post


Link to post
Share on other sites

I'm trying to convert Dune 2000 .aud -> .wav -> .voc to use in Dune 2.

First I used XCC Mixer to convert .AUD to .WAV.

Then I used the ms-dos utility wav2voc but seems that it isn't the correct way to obtain voc files, since the size from wave to creative voice remains the same, instead Dune 2 .VOCs are smaller and lite. The result is the game crash when a .VOC so big is played ("memory error").

 

Dynasty, do you know how to obtain custom Dune 2 .VOC files?

Share this post


Link to post
Share on other sites

Release notes from version 1.5.7:

  • Fix crash on startup when by using Spanish data files.
  • Put nouns before adjectives for Italian and Spanish.
  • Use English audio for Italian and Spanish.

Awesome, thank you for these additions! I'm posting some impressions.

1) There are some graphics missing, I don't know why. Some graphic icons are missing in several instances where they should be displayed, and even in the game I can't see any units. I'm posting some screenshots:

119td02.png

I suppose there should be some icons being displayed in the list from this revamped option screen, though I'm not sure.

14uvq0.png

The "accept" (Sí) and "decline" (No) graphic icons are missing here. You can either accept or decline your faction by guessing where the icons were usually placed in the original game and clicking them, but still you can't see them.

25ksxz8.png

It's the same here, there should be "confirm" (Proseguir) and "repeat" (Repetir) graphic icons here, but they are missing. You have to rely in the same icon placement guessing according to the original game that with the previous screen.

2psgfw1.png

Now here comes the worst problem. I can't see any unit at all. If you guess where they should be placed, you can click them and command them, but it's annoying to have invisible units for sure. Only when the foot units die, they appear laying dead.

24zdjt3.png

I can't see the building icons in the construction log either, only the names and construction progress appear.

Surely this must be some graphic loading issue, but I don't know the reason. Maybe I got some missing file in the data folder and that's why the program fails to load all these graphics?

2) I noticed there are additional language extensions implemented, because at first I put the "language=GER" string in the "dunedynasty.cfg" file to force the program to load Spanish language, but doing these the game keeps voiceless like it was originally. But then I tried "language=SPA", not only the Spanish language loads, but the units are all speaking English, which is awesome. So this way we can now have either a voiceless game or an English-speaking game with both Spanish ("GER" or "SPA") or Italian ("FRE" or "ITA") if we want. But surely wouldn't be better to have a proper language selector implemented in the game options, like the one Dune Legacy has?

3) There seems to be some text length issues during the intermission scenes, and the credits don't display at all because there's just a "T" letter being displayed endlessly.

2db86eq.png

This is in HARKONNEN INTERMISSION 2.

2ahdrp2.png

This is in ATREIDES INTERMISSION 2.

2d2jepk.png

This is in ORDOS INTERMISSION 1.

11l7juu.png

This is in ORDOS END GAME (that "!" shouldn't be there, but a blank space).

swec8y.png

And this is what happens in CREDITS.

4) Even if we have English-speaking with both mentat and unit speech, the intro still remains silent. Could you use the English narration in INTROVOC.PAK for both Spanish and Italian? As long as subtitles remain enabled, which is something that can be set up in "dunedynasty.cfg", there should be no problem (the original game had subtitles disabled when there was speech in the intro, but I tested Dune Dynasty in English and it's able to load speech and subtitles combined). The only exception I would consider would be skipping the "Dune: The Building of a Dinasty" line speech because that wouldn't fit with the retranslated "The Battle for Arrakis" European subtitles. In fact, even the European original game in English language skipped that speech line and played the rest of the voiced intro, but Dune Dynasty solved this by forcing English to display the North American subtitle rather than the European one.

5) Could the "Options" and "Credits" graphic icons ("Mentat" is the same, so that one can be skipped) be changed to those of each specific language? The original game had those translated for each language, but here they remain in English. You can notice it in the in-game screenshots I posted before.

6) Good thing about putting nouns before adjectives in Spanish, that's actually an improvement to the original game. Italian already had that in the original game because of using the same settings as French, but Spanish had that reversed because of using the same settings as German. I hope OpenDUNE is also having this small fix.

And now, something not language specific:

X) What's with the music? It changes the different compatible formats randomly, so one moment you are listening the Adlib music, then the MIDI music, then the Sega Mega Drive music, then the Dune 2000 music, and so on. I noticed there are different [music] strings in "dunedynasty.cfg" where you can either enable or disable them (so, since I have all them enabled with "1", that's why the program is randomly using all of them), but wouldn't be better to have a proper way to switch them in-game? There's only some sort of Sound Test in the options menu, but not a proper option to switch the sound and force the game to stay with that one.

Share this post


Link to post
Share on other sites

I found a new issue using the Spanish version in Dune Dynasty. It happens in the map screen of Harkonnen level 9 (last level).

5x4hhl.png

This error messages pops up just when the selection arrows are going to blink. It only happens in this map screen, though. The rest of sides and levels map screens have the blinking arrows working perfectly.

Regarding OpenDUNE, I just tested the last update done to pre v0.8. It fixes the problem with the intro and the mentat briefings, but it adds a new "line disorder" in the title screen menu and the game options menu which wasn't happening before.

These shouldn't be like this:

2pqw613.png

2w3q91d.png

op6bfp.png

Rather, they should be like these:

1sdtdw.png

28s7y86.png

25a6pzl.png

I suppose this is still related to the deleted worm string that's giving so much problem to make the Spanish version fully compatible. It doesn't happen with Dune Dynasty though, only with OpenDUNE.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×