Jump to content
ArkAngelMyk

Old problem with Emperor on Windows 7

Recommended Posts

I know I had this problem before and I am not sure how I fixed on a previous Windows install (XP I think).   

The game runs fine except when you select multiple units. Then the game stalls for a few seconds then jumps forward at super speed to catch up to where it should be if it had not stalled.  Other than that game runs great.

Windows 7 64 bit

Intel Core 2 Quad q6700

8 gb ram

Nvidia 9800 gtx+

Nvidia drivers from 6/18/09

Share this post


Link to post
Share on other sites

as far as i concluded when it happens to me (it happens maybe 2 times in a whole match) is that my CD drive starts to run, so i assume he needs to catch up on reading data.

can't say anything else about it

Share this post


Link to post
Share on other sites

I am running windows 7 64 bit as well, and have the exact same issue. Any time I select more than one unit, my game starts freezing, then hauls ass to catch up.

I am however running the game via an ISO (I always run whatever game I'm playing on an ISO via my SSD, works the fastest) so it has nothing to do with the CD drive.

It may be that I am running two monitors, but I'll look more into it and report my findings here. As it is, I can't even play d2k on vista/7 :(

*edit*

Two monitors isn't the issue, an update on drivers isn't correcting it, a different hard drive doesn't work either.

The only possible thing I can see working is a virtual machine. I will report back on my findings there.

Share this post


Link to post
Share on other sites

dual core, maybe? I've heard of switching to single core solving similar problems. The cause of such problems is usually that since an app designed for single core runs on dual core, the processes ran on the different cores don't stay synchoronized.

Share this post


Link to post
Share on other sites

I'm running Win7 x64 7600.blahbling.rtm , same hardware as OP except ATI4890 and X-Fi...

Ebfd  runs fine for me, no  hitches, no issues, no compatibility modes

although i haven't tried the campaign yet, Is that where the problem is?

The dual core issue i think Nyerguds is referring to is the Amd64x2 series(they need a driver fix,yes)

Unless you mean changing affinity from the task manager?(both?)

Update sound drivers too! as well as motherboard chipset as per usual

But seriously, i'd disable sound to see if that's the issue first, don't fix anything that's not broken :)

Maybe there's an nvidia 3d setting that the game doesn't agree with perhaps, just a guess

Lastly, what is the build of win7 you have there?

Share this post


Link to post
Share on other sites

I am still using the 7100 RC 64 bit build.  I haven't found any access to the RTM build and I figured if I am going to redo my HD when I get it I might as well wait till Oct when it comes out. 

Share this post


Link to post
Share on other sites

I'm using full Windows 7 with nvidia GeForce 8700 GT, 4GB Ram, Intel Core 2 Duo T9300 2.50GHz. I'm also having this odd issue. I tried setting the compatibility mode for several versions, but it runs okay (except for the multi-group lag) on 7. Also, setting the 3D graphics didn't seem to help.

I have been trying skirmishes, just to troubleshoot the issue, but i'll try campaign to see if it works there.

Thanks and good luck!

Share this post


Link to post
Share on other sites

Nope, still having the problem in campaign mode too. I have tried all the settings at the lowest, but it still happens.

Share this post


Link to post
Share on other sites

The dual core issue i think Nyerguds is referring to is the Amd64x2 series(they need a driver fix,yes)

Unless you mean changing affinity from the task manager?(both?)

I was talking about the affinity thing.

Share this post


Link to post
Share on other sites

Hi,

I was working on a speedrun for Emperor and halted for a quite long period of time. Then I wanted to finally finish it... so after upgrading to Windows 7. I noticed the issue you are all talking about.

No one has said how it actually looks like. It not only freezes but glitches the interface for a moment. This is what it looks like -

game2009121312094301.jpg

So it is very possible that this is an Nvidia Graphic card issue which happens only on Windows 7. Because I had XP 64bit before with the same video card.

The glitch is very odd after you try to swich the game speeds you sometimes manage to control multiple units up to 100 until the glitch occurs again after selecting another group!

Well I doubt I'll be switching to an ATI card anytime soon so I'll stop the run.

You can read about the run here if you're interested - http://speeddemosarchive.com/forum/index.php/topic,9295.0.html

Share this post


Link to post
Share on other sites

I think it comes more often with scrolling the view. And more often with using mouse to scroll the view.. So better keep mouse cursor more in the middle of the screen and use keyboard to scroll, but I'll have to do more testing if this is the case.

Share this post


Link to post
Share on other sites

I'm on Win7 64 bit with dual cores (AMD). I've used both an ATI Radeon and an on-board NVIDIA chipset -- both without incident. Try disabling things from your NVIDIA control panel (things like vsync). Also, what settings are you running the game on? Does it happen irrespective of whether it's on High/Low gfx settings?

Share this post


Link to post
Share on other sites

Changing vertical sync off made the game behave more erratic. Scrolling and rotation speeds were too fast, well scrolling speed was ok if I set it 1. The game crashed more. Resolution change seems to have the most effect. I could play 640*480 and other settings highest without glitching or it happens very rarely and very minimalistically. 1024*768 seems okayish, some glitching, but I didn't get it to get into a complete stop like with 1280*960 and I was constantly scrolling around and having units selected.

Share this post


Link to post
Share on other sites

sadly my personnal computer has struck this problem. My dual core 2.2ghz and 9600 gt runing win 7 enterprise 64 bit crashes at this time, while my 32 bit win 7 enterprise 1.8ghz dual core with intel integrated runs it fine.

Share this post


Link to post
Share on other sites

I tried running it with ram set at 2 gigs and using just a single core but it still is the same.  I still feel that this is an Nvidia issue somewhere that I havent been able to solve within the Nvidia settings

Share this post


Link to post
Share on other sites

I tried running it with ram set at 2 gigs and using just a single core but it still is the same.  I still feel that this is an Nvidia issue somewhere that I havent been able to solve within the Nvidia settings

Had a similar problem with the game speed on dune 2000 with an nvidia gpu, integrated seems to remove the problem.

Share this post


Link to post
Share on other sites

ive just re installed the game after finding it and im having the same problem, im running windows 7 which seems to be the problem, has anyone found a way to stop the graphics glitching when moving units

Share this post


Link to post
Share on other sites

Gruntlord are you saying you got Dune2k to work on windows7?  if So may I ask how you did.

I used the intel integrated chipset, its a problem with nvidia and ati drivers.

Share this post


Link to post
Share on other sites

Actually in regards to Dune2k I was wondering how you installed it with an 8 bit installer.  I know the program will work if you can find an installer because I had it on another hard drive that it would work through at one time.

Does anyone know how to change your audio acceleration to basic in windows 7?  It used to be in the audio settings way back in XP but since Vista I have not found the slider.

Share this post


Link to post
Share on other sites

Actually in regards to Dune2k I was wondering how you installed it with an 8 bit installer.  I know the program will work if you can find an installer because I had it on another hard drive that it would work through at one time.

Does anyone know how to change your audio acceleration to basic in windows 7?  It used to be in the audio settings way back in XP but since Vista I have not found the slider.

Its actually a 32/64 bit hybrid installer. Many professional companies use it.

Share this post


Link to post
Share on other sites

What is the installer called ? And is it publicly avaiable?

It has to be a Nvidia thing as far as Emperor I tried using just one core and 2 megs of ram with the same results.  One question I am wondering is if it is using some form of Open Gl for the graphics.  Windows 7 seems to have big issues with Open Gl, so far I have not been able to run Open Gl on Windows 7 though there is supposed to be a way with OpenGl 3.0

Share this post


Link to post
Share on other sites

I also have this issue. I have a nVidia geforce 9600m GT, and whenever I select multiple units the game gets glithcy, freezes and often crashes. Have tried so many things already and can't get anything to work :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...