Jump to content
Gruntlord6

Windows 7 or Vista Problems?

Recommended Posts

There must be a solution for that problem somewhere around here, but I don't know the details, sorry!

Share this post


Link to post
Share on other sites

The Dune installer gives me a 509 error, are there any mirrors?

The link has been fixed.

Share this post


Link to post
Share on other sites

Hey Gruntlord, I'm getting the "Blt - An exception was encountered while performing the requested operation. [ gGameticks = 0 ]" error that Prophallus had, with the game giving a black screen and then crashing right at startup, and can not get around it. I know I had D2K running on this machine before, but I had to reformat my OS drive, and I can't get it working now. I downloaded your installer, ran it, ran the 3 patches (can't find a download for 1.5.2), ran the VB Runtime file, and still nothing. I have Win 7 Ultimate x64, 16gb RAM, an AMD Phenom II x4 980, and dual Radeon HD 6870s. I've downloaded and installed literally dozens of classic games, so I'm no noob, but for some reason this one is just not working for me...

Share this post


Link to post
Share on other sites

I SOLVED IT! At least on my computer, I was getting a gGameticks = 0 error, despite everything I had tried. Turns out, D2K can't handle CrossFireX setups. So what I did, is in the newest versions of AMD Vision Control Center, you can create custom profiles for each game. So open Vision Control Center, and on the left click "Gaming" and then under that click "3D Application Settings." Scroll all the way down to where it says "AMD CrossFireX Mode for 3D Applications" and in the drop down menu select Disabled. Then go back to the top and make sure the first drop down menu says "<<New Application>>" and click save. Here it will ask you to locate the game executable that will use this profile. The trick is, setting DUNE2000.EXE won't work, so you have to go to the bottom right corner of the window and where it says "Programs (*.exe)" click the drop down and select the only other option, "All fIles (*.*)" Now navigate to the folder where D2K is installed, and select DUNE2000.DAT and hit enter. Now you should have to hit "Apply" in the bottom left corner of Vision Control Center to make it stick, but other than that, the game should run perfectly now!

Share this post


Link to post
Share on other sites

My issue is pretty similar to the one of other Windows 7 users: I installed Dune 2000 (even tried several different version, including the gruntmod one), but when I run the game (tried every compatibility option) the intro vid plays but after that, the menu remains empty while the music still plays and I have to close dune via task manager, since there is no menu to choose from ingame.

my sys:

OS: W7 x64

i7 3770k

RAM: 8GB

GFX: GTX 580

MOBO: Asus P8Z77V-Deluxe

The strange thing is that it worked flawlessly with my previous Vista x64 sys and a GTX 295, so could it be a gfx card issue?

Share this post


Link to post
Share on other sites

I SOLVED IT! At least on my computer, I was getting a gGameticks = 0 error, despite everything I had tried. Turns out, D2K can't handle CrossFireX setups. So what I did, is in the newest versions of AMD Vision Control Center, you can create custom profiles for each game. So open Vision Control Center, and on the left click "Gaming" and then under that click "3D Application Settings." Scroll all the way down to where it says "AMD CrossFireX Mode for 3D Applications" and in the drop down menu select Disabled. Then go back to the top and make sure the first drop down menu says "<<New Application>>" and click save. Here it will ask you to locate the game executable that will use this profile. The trick is, setting DUNE2000.EXE won't work, so you have to go to the bottom right corner of the window and where it says "Programs (*.exe)" click the drop down and select the only other option, "All fIles (*.*)" Now navigate to the folder where D2K is installed, and select DUNE2000.DAT and hit enter. Now you should have to hit "Apply" in the bottom left corner of Vision Control Center to make it stick, but other than that, the game should run perfectly now!

Interesting, gameticks=0 is a generic error (meaning the game failed before even a single second) which is why it was hard for me to resolve your problem. It makes sense that it doesn't work on crossfire. Thanks for documenting your fix.

On a side note, dropbox links are no longer being used. Google drive should have the bandwidth needed to support the game, but proper hosting solutions are being investigated.

Share this post


Link to post
Share on other sites

Your website seems to be down. I was able to open a cached version but it was sparse. I clicked a link i think is the file i need but im not sure. Im currently downloading Dune 2000.msi , Is this the file i need? also will i need to download any patches? thanks in advance

Share this post


Link to post
Share on other sites

Hi guys so iv read around for days now and am desperate to get this game to work. I'm getting the black screen with sound in background, ya'll know the problem lol

So got windows 7 ultimate 32 bit, Intel pentium 4 (3.00 GHz), 1 GB ram, geforce fx 5900 graphic (8bit 256 mb I think)PC connected to 40 inch LCD screen through dvi and I keep getting this

Dune 2000 requires a 256 colour desktop to run.

This video card does not support the required modes.

Insufficient RAM and/or Virtual Memory. Check Virtual

Memory settings and disk space to ensure at least 12Mb is

avilable.

File not found

Please reinstall"

I tired all older compatibility modes for older windows with 256 colours and run at 640 x 800 (what ever resolution), I'm running out of ideas, I tried 3 or 4 different versions I found on the internet which all do the same thing, I'm going to try a legitimate disc copy tomorrow borrowed from my brother. Also to note I think my geforce card does support 256 colours as I used that mode to test and it makes everything go very funky looking on my TV.

I keep hearing about this Grunt Mod version but no where can I find a download link for it to get the game to run.

Setting up a virtual machine might be just beyond my capabilities as never tried anything so advanced on a computer.

I think is it cos I'm playing through dvi and resolution is getting pushed above what compatibility mode should or my graphics card needs swapping?

Help please and keep on with the mods Gruntlord you do a grand job and can't wait to join in!!!!

Share this post


Link to post
Share on other sites

Another thing, in my set up I forgot to mention I think I have directx 11 installed but not too sure and also I can't find any older drivers for geforce fx 5900 there seems to be none but I hope I'm wrong about that.

If you guys could help a noob it would be great!

Share this post


Link to post
Share on other sites

Ok so to update you guys, i got a copy of dune 2000 on cd and ran the installer fine, played the intro 1st movie and 2nd (the sister talking about the prophesy) which is all good but after the end of that movie i get black screen and no sound, windows says dune 2000 is still running but the only waybf exit is through windows control panel.

Does this help in any way? So play HW is up to hte challenge of playing a couple of movies but not further(bear in mind this is the furthest i have got on this PC Hope to hear from you guys soon!

Share this post


Link to post
Share on other sites

I have patched to 1.0.6 and the game still wont play, i can veiw the intro video and it freezes after, wont load to main menu.

Please please please can someone post a link to gruntlords installer? i have searched and searched and searched and there is no working links anywhere i can find, come on guys

Share this post


Link to post
Share on other sites

I have patched to 1.0.6 and the game still wont play, i can veiw the intro video and it freezes after, wont load to main menu.

Please please please can someone post a link to gruntlords installer? i have searched and searched and searched and there is no working links anywhere i can find, come on guys

https://drive.google.com/uc?export=download&confirm=no_antivirus&id=0B9v-5nLhH3CYQWIwY080ZXNaMW8
  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks a ton really appriciate it, i thought this place was a ghost town. I got in on the party 2 years too late lol So got it downloading, what do i do with the .msi file type? Does it extract or will it run hte installer if i click it or?

Edit

ok got it installing, im just not familiar with msi file type as an extention.

A huge huge huge thanks for you sorting this link Gruntlord, honestly you have no idea of my level of gratitude! :)

Share this post


Link to post
Share on other sites

OK so downloaded it and installed, how do I actually play the game as there's no options within the main menu? Sorry for sounding so nooby.

I use another forum regularly to do with android and I know nooby questions can be a pain

Share this post


Link to post
Share on other sites

what do u mean with no options in main menu? u see the dune logo but no buttons like new game, multiplayer etc. ?

Share this post


Link to post
Share on other sites

Thanks for your reply, I was half way through writing a post in your guide thread. So when I launch dune and reach the main menu I see no buttons to launch new game or skirmish or options etc There is a black window with nothing inside where the buttons should be.

Share this post


Link to post
Share on other sites

lol.. never heared of this (if i understood correctly, u see dune logo but in the middle where should be buttons its black).

Have no idea, some ppl never managed to get this game working on win 7. You can try downloading the multiplayer patched version which i posted on this thread forum.dune2k.com/topic/24242-dune2000-online-game-patched-for-hamachi-no-more-crashes-habb-erg-2-map-included/#entry375133

If still not working, try setting up a virtual machine, win 98 or 95 will handle the game well from what i think, and virtual hdd for these 2 can be found easy.

Share this post


Link to post
Share on other sites

OK great I'll give that a try, was hoping to avoid trying to set a virtual machine as I feel it could be a bit beyond me but I'd learn something, I know my way round android OS so its just unfamiliar territory for me doing read advanced stuff on a PC like that. Any way thank you for taking the time to reply to me, I'll let you know how I get on. Cheers!

Edit

Just to clarify you did understand correctly what I meant, main menu launched with the picture of a face and rocket tank launching missiles, in the middle there is the box where you would start or load a game or options and stuff, the whole thing is just black. Perhaps I'll try the repair option within the installer as first time I tried it said the launcher of some sort was missing and repairing fixed it so perhaps I'll get lucky third time eh :)

Share this post


Link to post
Share on other sites

No prob, i wish i could help more but im posting from a cell phone (samsung galaxy ace - yes with android :D ).

Setting up a virtual machine is quite easy. Download microsoft virtual pc , then get a win 98 .vhd file (unless u havea win 98 cd).

EDIT: i will try to help u more tomorow when i start the pc. Now here is evening lol :D

Share this post


Link to post
Share on other sites

Nice. I got galaxy nexus and posting from it too. I edittes my post to give a little more detail. Thanks again and will let you know how I get on.

Share this post


Link to post
Share on other sites

have you tried to click on the black box? maybe u activate the buttons and it will happen something.

Share this post


Link to post
Share on other sites

I didn't try that, I got as far as the menu and saw the buttons were missing so used task manager to exit and reported the issue here

Share this post


Link to post
Share on other sites

@ Steve: I got EXACTLY the same issue you have, either a blank menu with sound or a black screen also with sound, depends on your type of dune installation, when deleting the intro vids from your dune folder, you only get the black screen. The strange thing is that it works fine on my vista 64 installation, which runs on the same pc my windows 7 64 runs on. so it only works with vista and not with windows 7 for me, regardless of the hardware, which is very strange. I even contacted gruntlord about this issue, since many others are experiencing this too, but he couldnt find a solution for it. I hope someone will find a solution eventually.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...