Jump to content

Dune 2000 Grunt Mods Edition on a 64-Bit system


shai
 Share

Recommended Posts

Does any one else play this version on a 64-Bit system because it runs very fast and if I quit or press the windows key/Alt+Tab then the entire system crashes and it needs to be reset by force. Is this a known problem?

Link to comment
Share on other sites

Win7 Prof, Service Pack 1, 64bit, Intel i5, ATI HD6900 series. No problem with Grunt Mod Edition. I did however download it some time ago, but that should not matter since it's just Dune 2000 with an installer and some know-to-work-patches (mission select etc.).

 

That your entire system crashes is a bit weird, I don't think a game can do that. I'm afraid your system is not completely stable. Try to run a chkdsk (google it) on the drive that Dune is installed, perhaps the HDD has some bad sectors. You could also try the usual stuff, like update windows, videocard/sound-drivers etc.

  • Upvote 1
Link to comment
Share on other sites

Win7 Prof, Service Pack 1, 64bit, Intel i5, ATI HD6900 series. No problem with Grunt Mod Edition. I did however download it some time ago, but that should not matter since it's just Dune 2000 with an installer and some know-to-work-patches (mission select etc.).

 

That your entire system crashes is a bit weird, I don't think a game can do that. I'm afraid your system is not completely stable. Try to run a chkdsk (google it) on the drive that Dune is installed, perhaps the HDD has some bad sectors. You could also try the usual stuff, like update windows, videocard/sound-drivers etc.

I would recommend running a stress testing program like Prime95 to see if that will crash the PC as well, I have yet to hear about an issue crashing the whole PC.

Your youtube video leads me to believe it is a motherboard issue, although it may also just be your monitor on your all in one not handling the display properly.

  • Upvote 1
Link to comment
Share on other sites

I would recommend running a stress testing program like Prime95 to see if that will crash the PC as well, I have yet to hear about an issue crashing the whole PC.

Your youtube video leads me to believe it is a motherboard issue, although it may also just be your monitor on your all in one not handling the display properly.

Probably, but it's not the monitor because it would only happen to Dune 2000, also Ctrl+Alt+Del was not doing anything. 

Link to comment
Share on other sites

Try to see if it crashes under 64 bit Linux.

BTW:

if you have a bad HDD, HDD regenerator can be your friend.

if you have bad memory GRUB can be your friend.

I installed 64 bit Ubuntu to test the RAM, but for me when I tried to play Dune on it, it also ran super fast. I also used chkdsk to check the HD but I did not see anything wrong with the results. But, strangely, even though there was nothing with the results, it stopped Dune from crashing the system. 

Edited by Shai-Gel98
Link to comment
Share on other sites

I installed 64 bit Ubuntu to test the RAM, but for me when I tried to play Dune on it, it also ran super fast. I also used chkdsk to check the HD but I did not see anything wrong with the results. But, strangely, even though there was nothing with the results, it stopped Dune from crashing the system. 

Dune running super fast is related to certain hardware/drivers. It basically runs at the maximum speed the hardware can render it at, which is not a playable scenario. I've only had this happen in virtual machines, but I've heard it happens in linux under WINE often.

  • Upvote 3
Link to comment
Share on other sites

Well, apparently the screen flashing and such IS the monitor, which seems to happen when the resolution changes, but why it would happen to Dune many times in a row and then stop when I run chkdsk, I don't know. 

Link to comment
Share on other sites

Well, apparently the screen flashing and such IS the monitor, which seems to happen when the resolution changes, but why it would happen to Dune many times in a row and then stop when I run chkdsk, I don't know. 

Probably was just acting up and the chkdsk is unrelated.

Link to comment
Share on other sites

Logically it should be unrelated. (If the HDD was heavily fragmented it could cause some issues-delays). Flashing IS Monitor issue-resolution's specs are "out of range" for monitor's capabilities. From my expirience with PCs many times I got flashing screens on CRTs with 640x480. Changing refresh rate solved those issues.

Link to comment
Share on other sites

I updated the installer on the webpage to 1.6.1.3. I resolved the issues with slow install times, and I also added to option to install the High res patch at 1920x1080. My upload is tied up for now, so the download link will point toward google drive.

Edit: The download link now points to gruntmods.com with the google drive link as the mirror.

  • Upvote 1
Link to comment
Share on other sites

Wow, that fixed it. Also, I found an error that I've never seen before, and it happens if you start the game with no headphones or speakers plugged in:

Audio_Init Error

 

Failed to create Direct_Sound_Object : 0

 

Has any one else here seen this? I've been playing this for 7-8 years and I haven't. 

Link to comment
Share on other sites

Wow, that fixed it. Also, I found an error that I've never seen before, and it happens if you start the game with no headphones or speakers plugged in:

Has any one else here seen this? I've been playing this for 7-8 years and I haven't.

saw this when I had no speakers..

10yrs back..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...