Jump to content

Geforce 8800 GTX


Recommended Posts

Has anyone with a GTX or any Geforce 8 series for that matter, been able to run Emperor. I can't. it locks up before loading the game. I've tried the NVIDIA forums and found no info, so trying it out here. Any help would be appreciated.


Intel Core 2 Duo E6660 @ 2.66 GHZ

Asus P5N32 Board

Geforce 8800 GTX

Windows XP SP2

4 gigs of ram 667 (ya i know XP 32bit cant use 4 gigs...)

Link to comment
Share on other sites

What no-cd Patch? i just use try using the updated patch. 1.09. or try to.

I know its a Driver issue, but NVIDIA isn't exactly going to care to fix an issue in a game that is old and is barely sold in stores anymore. Was wondering if there was a work around or reason.

Link to comment
Share on other sites

You need newest nVidia drivers for graphics card and 1.09 patch of course. I had same problem. Just dusted off my copy of Emperor, installed, and BANG! Stuck in 2 sec after running the game. Then I started to looking for a possible solution to my problem, and found it on a nVidia forum. New drivers allow Emperor to start with no problems. Fix apply to all 8800 series cards (I don't know about 8600 thou). I myself owning 8800 GTS EVGA 640 MB.

I running now Emperor nearly without problems (driver version for XP/2000 - 158.19). Nearly because max resolutions is set @ 1024*768 and I cannot increase it, but old 5950XT on AGP with old MB was able to show 1280*1024 without problems. But well, better 1024*768 than nothing!

I hope it helps.

My specs btw:

Core 2 Duo 2.4 GHz

2 GB RAM (2*1 Geil 800MHz)

XP Pro SP2

EVGA 8800 GTS 640 MB


EVGA 860i motherboard (AR version)

Link to comment
Share on other sites

I hope I won't have a problem when I switch to a 8800gtx soon.

limited resolution is not quite a fix of the problem for me... I play on 1600x1200 since years, unfortunately the game is too old to support widescreen resolutions like 1920x1200 but 1600 looks fine too...

Link to comment
Share on other sites

try disabling the games compressed textures by adding  -c to the command line of the games shortcut

eg: C:Program FilesWestwoodEmperorEmperor.exe -c 

the limited resolution could be a monitor driver thingy problem..

that is, maybe its installed a 'plug and play/default monitor'

the only other thing i would try before igniting nvidias forums is

tune your video acceleration level down 1 by 1 till it works..but dont set the lowest level :)

you should be able to find these settings in DXDIAG 

thats just a workaround and i dont recommend using it if you dont have any problems as it WILL slow your system!

Link to comment
Share on other sites

I have the newest drivers. Still no dice. Ill try lowering the res, can only play windowed so its probably the res.

Its a poorly programmed game because the rotate works so fast that one move makes it spin all the way around. poorly done.

Link to comment
Share on other sites

  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...