Jump to content

Emperor won't run under Win2k


Faetarius
 Share

Recommended Posts

Hi guys.

I've trawled through the forums looking for answers, but my game still won't run.

The game starts up, shows the Emperor splash screen, goes black and then...stops...

No error message, no other effect on my computer, nothing.

I've tried running the game with the patch (1.09), without the patched, with the install fix, with the patch and the install fix...

I also know that the cd isn't bad because the game used to run when I had Win98 installed.

Lastly I don't have Norton AV on my computer, I use Avast!

Any ideas guys? Thanks

Link to comment
Share on other sites

Where do I find the compatability mode? I thought that was only a feature of WinXP?

I know my virus checker isn't to blame, I've had this problem since I installed Win2000, even before I added any virus scanning software of any description

Link to comment
Share on other sites

I found the compatibility mode, but it doesn't want to work.

With the Win95/98 modes the I get the error: A debugger has been detected. Unload the debugger and try again.

With WinNT mode the game starts, but then says that I need to insert the correct CD-ROM. This message appears no matter which disc I put in the drive.

Link to comment
Share on other sites

Try going to Control Panel/Display/Settings then click Advanced.

Go to the Troubleshooting tab and lower the slider one or two notches. Dont go more then that, becuase I dont think Emperor will work without cerrtain functions there.

See if that helps.

Also, have you got the latest drivers. Did you use the install-fix correctly ?

Link to comment
Share on other sites

As far as I know I installed the fix correctly. I tried it twice to try and make sure it wasn't me that had screwed up the fix.

My drivers are up to date, or very close to that (1 version or so out)

I tried the troubleshooting slider. Down 1-2, no dice. Down three and I got a different error message: GAME.exe has caused errors and will be closed by windows.

(BTW: I've been through tech support with an identical problem in RA2, they couldn't solve it either)

Thanks for the ideas though guys

Link to comment
Share on other sites

Sorry to hear you have no joy.

The troubleshooting slider needs to be up to a certain level or even a working system will fail when Emp finds no 3D acceleration. the different error message was probably becuase Emp didnt think you had DirectX or a 3D card or something along those lines.

Make a system restore point and try the omega drivers. A wild guess, but seeing as there doesnt seem to be any hint to go on... A google search for "omega graphics drivers" should sort it out.

Also, make a shortcut to the game, place it somewhere, and in the line that reads Target, add the switch "+W" to the end.

Mine reads: "E:Program FilesgamesemperorEMPEROR.EXE" +W in total.

See if that helps. (I think you can also try -W which runs in a window, totally unplayable but something to try,)

Link to comment
Share on other sites

What video card/integrated graphics are you using? I know it runs fine with Win2k pro, and the last time that ever happened to me was due to resolution setting and an older driver install. But maybe not the case for you I dunno.

Link to comment
Share on other sites

Yea, I tried the things you suggested. No dice.

I've got an ATI Radeon X800, shouldn't be a problem.

The rest of my system is also well above the minimum specs, could my computer just be trying to start too fast for the game?

Link to comment
Share on other sites

  • 3 weeks later...
  • 9 months later...

I FOUND OUT WHAT THE PROBLEM IS!!! update windows 2k, run the installer for emp, NOW THIS IS IMPORTANT!!! before you play it, restart your computer, if you dont do this you will need to reinstall. it should work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...