Jump to content

Anyone have this bug before and how to fix it?


Recommended Posts

On 8/13/2020 at 6:11 AM, Fey said:

The AttackBuildingStrength parameter is a percentage of total available units. If you want them to send everything, gotta set that to 100. There shooould be an AI manual included the with the editor! :) If that helps.

And yeah, TibEd has a bunch of issues. To mod the sound completely, you actually need to edit the hex. I posted details about it here:

https://forum.dune2k.com/topic/28668-regarding-unit-dialogue-modding/?do=findComment&comment=399758

Hope that helps.

Hi Fey,

I tried these setting for AttackBuildingStrength parameter in my custom map with 5 AI and it is not working the way you describe it! They send units but not all they have! and then the ally never sends anything, i tried setting him to 200 so maybe if his ally sends 100% he will send the other 100% cause he is set to 200. I can send you my mission file if you could take a look that would be Awesome!

_O9V2.MIS

Link to post
Share on other sites
2 hours ago, maltebyte02 said:

Hi Fey,

I tried these setting for AttackBuildingStrength parameter in my custom map with 5 AI and it is not working the way you describe it! They send units but not all they have! and then the ally never sends anything, i tried setting him to 200 so maybe if his ally sends 100% he will send the other 100% cause he is set to 200. I can send you my mission file if you could take a look that would be Awesome!

Ah yeah, no point to putting it above 100.

I should clarify: The AI will send 100% of all UNASSIGNED units every time it wants to attack. Meaning, any units that are already assigned to defend their base will be ineligible to be called by the AI for an attack on your base. You can disable this behavior by setting the GuardGroupSize to zero, or by toggling "unknown byte 29" at the bottom of the AI parameters list off (put a 0 there where there should be a 1). Here are some screenshots:
https://prnt.sc/zuocxl
https://prnt.sc/zuofxa

Note, however, that doing so will make the AI ignore your units when you're attacking their base structures. They will only assign those units to attack you. They will protect their Harvesters and stuff though.

If you want them to send the pre-placed units, the units they start with at the beginning of the map, you'll need to free them up, else they'll sit there on guard mode. To keep them free from the start, change the FreePercentage to anything other than zero:
https://prnt.sc/zuohmf

Regarding the mercenary ally, they can be fixed by not only changing the parameters above, but also boosting their Unit Build Rate. The lower the number, the faster they'll build units. Set to 1 to make the AI attempt to build a new unit every tic (1/25 of an in-game second):
https://prnt.sc/zuoq53

You can also change the unit composition an AI will use by adjusting the relevant priorities. It's based on ratios, so you can tell the AI, "I want you to build one Combat Tank for every three Troopers." They'll look similar to this, only with different names since mine is obviously modded:
https://prnt.sc/zup9ua

You may want to give an AI that produces units more often a better starting economy to support their manufacturing. Another Refinery, maybe a couple more Harvesters.

Anyway, hope that helps you out. :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...