Jump to content
cdk

Campaign scenario 8 freezes at initial cutscene

Recommended Posts

Finished the first 7, started 8 (Orient) briefly but did not save it.  Now that sceneario and all after it freeze when it tries to play the initial cutscene (the first 7 and the standalone scenarios still work).  Have tried deleting all savegames, rebooting the machine (Windows 7/64), running in Win98 compatibility mode, and uninstalling and uninstalling/reinstalling the game.  No joy.

Anyone seen anything like this?

Share this post


Link to post
Share on other sites

What do you mean by "cutscene"? Is that something peculiar to the campaign?

I am not familiar with how the campaign is strung together, so I don't know what metadata file it might use. You might look through your RR Tycoon files for anything having a recent date.

There's a command line parameter for the game that prevents it from playing the game-start video. Setting it might stop the cutscene too, allowing you to get past it.

I hope you only moved your saved games rather than deleting them. You might need to resume from an earlier save point that was functioning correctly.

Share this post


Link to post
Share on other sites

"Cutscene" means the video that plays after you select a scenario but before the map displays (all the campaign scenarios have them).  If you can tell me how to start the game with cutscenes disabled that would be great; maybe it would fix my problem.

There are no files at all in the installation directory with today's date (my most recent reinstall) except a savegame of scenario 6 (you must play #6--even if you resign--to reach #s 7-12).  

Share this post


Link to post
Share on other sites

I've never had any trouble with the "cutscenes" but I normally play the Platinum version (1.56) with all the movie files etc. (anim folder i.e the .SMK files) copied to the hard disk (keeping the CD structure). Also you don't need to play the scenarios in any order - just scroll the campaign scenario selection screen using the left/right  cursor keys/ I normally don't play the cutscenes through, just mouse click when they start.

The downloadable versions may differ.

If You could work out which if any SMK file is "faulty" you could maybe copy a different file over it, but I have no idea which exact file it may be.

Also I use win 7 32 bit.        

Share this post


Link to post
Share on other sites

The file that is crashing is probably CV08.SMK - Try downloading the Smacker Rad Video tools from http://www.radgametools.com/smkdown.htm and install them and see if the file will play in that outside Railroad Tycoon. However they may not work on a 64 bit Operating System - the download page only mentions Operating Systems up to Vista.

Don't forget if you install RT2 in the Program Files folder on Win 7 (Vista?) or later the save files are under your hidden appdata folder <Drive:>USERS\<USERNAME>\AppData\Local\VirtualStore\ , not necessarily where the program files themselves are so you may need to delete those savefiles etc too just in case one is corrupt. Your individual settings too could be there Maybe reinstall to a folder outside program files to avoid the issue. Rereading your post suggests a corrupt save file might just be an issue. It seems odd that 1-7 are OK and 8 onwards are not.

Hope that helps. - if CV07.SMK is OK you could try copying it to CV08.SMK (keep a copy of the original). Try reading the readme file with the game as this mentions what to do if videos are slow running etc. 

Edited by Silverback
Update - to insert 64 in may not work on 64 bit Operating system
  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks.  Those tools are not self explanatory, but I discovered that  ALL the cutscene files were missing for the most recent re-install.  Copied them by hand #8 still has something wrong with it, but if hit ESC within a second I can play the scenario.

Share this post


Link to post
Share on other sites

Glad you found a work round.

When installed from CD/DVD  the cutscene files are never automatically installed but run from the disc. They always needed to be manually copied to to the installation folder for best performance. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...