Jump to content
Sign in to follow this  
Hauptillusionator

[problem - solution] Dune in DosBox without Sound - What to do?

Recommended Posts

Recently i dug out one of my favourite games, dune. I had no problem to run it in dosbox, but the sound didn't work. I wasted 3 hours with setup configuration, internet research, etc...

Then, by accident, i found in a downloaded dune version another .bat file, which included different parameters than the original dune.bat. And suddenly the sound worked. I thought I should post it here, maybe smbdy is struggeling with that too.

Edit dune.bat like following:

@echo off

logo

duneprg GER VGA SDB2207 EMS 386

logo: displaying the cryo logo at the beginning, you can delete this line if you want to.

duneprg: this is real dune game program

GER: parameter for german language (ENG for english)

VGA: parameter for VGA Graphics

SDB2207: i don't know exactly what this means, but you have to write this parameter to hear the sound! (soundblaster)

EMS: Using expanded memory

386: Using a 386 or better (i'm not sure about that)

You'll maybe have to load the soundblaster driver in dosbox. (You'd better read the dosbox instructions, following settings work at my computer, but maybe not on yours):

SET BLASTER = A220 I7 D1

I have to admit that I don't understand everything I wrote down here, but finally dune worked fine in my language with sound!

Have fun!

Share this post


Link to post
Share on other sites

SDB2207: i don't know exactly what this means, but you have to write this parameter to hear the sound! (soundblaster)

<...>

You'll maybe have to load the soundblaster driver in dosbox. (You'd better read the dosbox instructions, following settings work at my computer, but maybe not on yours):

SET BLASTER = A220 I7 D1

Well, all this means that Sound Blaster IO address is 220, IRQ is 7 and DMA is 1, which are the default DOSBox settings.

Share this post


Link to post
Share on other sites

Thank you so much for your quick solution - This should be the nr 1 google page for dosbox sound problems with dune 1.

Again, kudos to you.

Share this post


Link to post
Share on other sites

IIRC you need original MT-32 BIOS ROMs for MUNT to function (I think you need to have original MT-32 hardware to obtain a BIOS ROM).

Share this post


Link to post
Share on other sites

IIRC you need original MT-32 BIOS ROMs for MUNT to function (I think you need to have original MT-32 hardware to obtain a BIOS ROM).

It's working properly. Made this video with that:

Just dont know how to fill this line if I want mt32:

duneprg GER VGA SDB2207 EMS 386

MT32 is not appropriate of course.

Share this post


Link to post
Share on other sites

Here's what DOSBox Wiki says about the use of MUNT:

Munt is an open source project that aims to emulate the MT-32 hardware by way of a Windows XP WDM driver. Using it, however, requires a copy of the original ROM images from a Roland MT-32, and these are not included with the download. Installation notes are provided within the distribution archive.

Well, I assume you have that one, otherwise DOSBox just uses its internal MT-32 emulation (lower quality)

Anyhow, IIRC Dune should have a sound device configuration programme that allows to set up the sound in the game. Have you tried that?

Share this post


Link to post
Share on other sites

Recently i dug out one of my favourite games, dune. I had no problem to run it in dosbox, but the sound didn't work. I wasted 3 hours with setup configuration, internet research, etc...

Then, by accident, i found in a downloaded dune version another .bat file, which included different parameters than the original dune.bat. And suddenly the sound worked. I thought I should post it here, maybe smbdy is struggeling with that too.

Edit dune.bat like following:

@echo off

logo

duneprg GER VGA SDB2207 EMS 386

logo: displaying the cryo logo at the beginning, you can delete this line if you want to.

duneprg: this is real dune game program

GER: parameter for german language (ENG for english)

VGA: parameter for VGA Graphics

SDB2207: i don't know exactly what this means, but you have to write this parameter to hear the sound! (soundblaster)

EMS: Using expanded memory

386: Using a 386 or better (i'm not sure about that)

You'll maybe have to load the soundblaster driver in dosbox. (You'd better read the dosbox instructions, following settings work at my computer, but maybe not on yours):

SET BLASTER = A220 I7 D1

I have to admit that I don't understand everything I wrote down here, but finally dune worked fine in my language with sound!

Have fun!

Thank you so much! This was really useful to recreate an old and great experience!

More people like you are needed!

Share this post


Link to post
Share on other sites

Hi

I've recently got the game working on DOS box and followed the information above; I have music but no voice sounds... I'm sure the game had voice actors for the characters in the game.

Can anyone shed any light please?

Cheers

Share this post


Link to post
Share on other sites

It is possible the version on Dune you have doesn't come with voice sounds? I think that happened in a certain version to save on download size? Happens on other older games. I'm not sure.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...