Jump to content

Dune 2 Hall of Fame troubles


Recommended Posts


After the first mission, I'm needed to enter my name in the Hall of Fame. But whatever i do the game does not react when i hit enter. The cursor keeps blinking and i can edit my input, so the game doesn't freeze. I have to kill the game. I'm playing as Harkonen if it makes any difference.

I use D2 1.07 in Dosbox 0.73.

Ive searched these forums and goggle, but only in abandonia's Dune 2 discussions forums i see someone have the same problem, but there is no solution.

Does anyone have the solution? I would appreciate it very much since its been 10 years last time I've played Dune 2.

Thank you in advance.

Link to comment
Share on other sites

Do you have num lock on? I've seen it ignore keys over that... though that's mostly with arrow keys.

Ive tried to play it on another computer and it works fine. Num lock was on, but i will try it on my own computer later this evening.

Try both enter keys?

Yes, I've tried both.

you could try just playing without DOSBox... if you got a 32-bit windows that is.

In running W7 64-bit, so that is not possible. Dosbox is apparently the only option for me.

Link to comment
Share on other sites

Honestly I've never encountered such an issue, but you could try using the DOSBox key mapper (Ctrl+F1) to bind "Enter" to another key on your keyboard. Maybe it'll work.

Sounds like an solution, im gonna try that aswell when i get the oppitunity. Also i noticed that disabling the Num Lock will make the Numpad Enter key ineffective in Hall of Fame, and since i play on a notebook, where i believe it always is disabled, that might work too.

I will try all this out and let you know later.

Thank for all the suggestions and help so far.

Link to comment
Share on other sites

Hi all.

Status is it did not work the solutions you suggested. Ive tried Dosbox with Dune2 on several computers now and it only appears on my own. Fate is cruel!

Within a week or 2 i need to reinstall my windows, so im gonna try then.

Im gonna get back to you with a soultion when i find it, so others who experience this fault can quickly fix it.

Link to comment
Share on other sites

Small question... did you try simply changing the keyboard of your PC?

If I'm not mistaken, the PC in question is a notebook.

I thought that maybe the problem lies in that the game cannot/is not allowed to write the input into the hall of fame file? Check if the game directory and/or the files inside are not marked as "read-only". Also, have you tried reinstalling the game? Or simply deleting the old SAVEFAME.DAT file (the hall of fame data), if there is one.

Link to comment
Share on other sites

Please test stuff like that first, mrFlibble... a read-only savefame.dat causes this error at the moment you press [enter]:

Could not find file 'SAVEFAME.DAT'.

Insert disk 0 containing

'SAVEFAME.DAT' into any drive.

I could continue after tabbing out and making the file writable again.

Also, you can just plug a USB keyboard into a notebook.

Link to comment
Share on other sites

Please test stuff like that first, mrFlibble...

I don't have the time to test every hypothesis like that :P Besides, something else could be wrong with the file, and checking would not hurt anyway. However, it seems to me that the problem lies in somewhere between DOSBox and the native OS, or between DOSBox and the game, rtaher than in the game itself; perhaps it is worth a try using a different (earlier) build of DOSBox?

Also, you can just plug a USB keyboard into a notebook.

Sounds like a clumsy solution to me. E.g. I don't have a USB keyboard at hand, so I'd have to go buy one, just to play a game?

Link to comment
Share on other sites

Hi all.

Thanks for your replies on this issue, but i think ive isolated the problem. Dosbox seems to function incorrect on my computer, so the fault is software and located in the DosBox program. Some of the functions in DosBox like CTRL+enter(enter/exit full screen) does not work and keymapping dosent work either.

I will try to reinstall windows at some point, because ive allready tried to reinstall Dosbos without it helped.

I will get back to you whenever the situation changes.

Again, thanks very much for your help everyone.

Link to comment
Share on other sites

Hi again guys.

Just reinstalled my computer again with W7 but unfortunately it didnt work. It must be the hardware on the notebook and guess what... Ive just tested it with an USB Keyboard and it worked. I will now start looking for a wierd thing such as drivers for this keyboard. Maybe DosBox is loading an incompatible KBD driver but thats guessing.

I will let you know how it turns out.

Best regards


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.