Jump to content

Demo4 - Very obvious bugs


Recommended Posts

Firstly great project I can't wait to see the finished game!

I downloaded the Demo4 today and played through a couple of the levels but for some reason now my Refinery is not available to build from the menu! The build menu just seems totally messed up which has stopped me from being able to play on. I have tried to download it again but still the same issue!

Any one else had this issue?

Link to comment
Share on other sites

Not being able to build a Refinery is a major bug. Perhaps you could give some more info.

- When exactly did you get this bug? Level and race you where playing with.

- Can you give us a visual? Posting a screenshot?

- Did you have enought credits for the Refinery?

- Did you build a powerplant before hand?

- Perhaps you could send Stefan a log from your last game?

- It's obvious you can reproduce your bug. Can you tell us what you exactly did? Perhaps someone else can reproduce the bug as well.

Link to comment
Share on other sites

I loaded up any campaign with any house and used the debug mode to take me to mission 9. As soon as the game started I upgraded my construction yard and built some concrete slabs. I then built the wind trap and you will see on the image there is no refinery for me to build!


This also happens on skirmish and after any campaign that I get to where you can upgrade the cons yard. If I don't upgrade my cons yard once I have built my refinery I get no new build options so can't build any tanks or quads.

Let me know if you need anything else.

Link to comment
Share on other sites

This might sound strange, but have you tried to scroll down in the build menu? There are 2 arrowheads (triangles), 1 pointing up and 1 pointing down. You need to press on the one pointing down.

Link to comment
Share on other sites

I have tried to reproduce this bug. I built some slabs, upgraded to 4SLABS and then built a windtrap.

It is true, you have to scroll down the list (use your mouse scroll wheel, its easier than clicking on the up/down button) and you'll see it there. It is not that obvious, I can imagine why you would say its a bug.

Link to comment
Share on other sites

  • 3 weeks later...

Hi all,

Just found this 'game' and totally love it.

I have noticed a few bugs as well;

1. When playing the campaign, on the 2nd or 3rd mission, sometimes my units just stop doing what I tell them to do, select and tell them to do something and they don't do it.

2. When I tell a unit (say, siege tank) to attack a unit, the 'body' of the unit turns to face the target AND THEN the turret turns and then it fires... can this be fixed?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...