Jump to content

Game freezes INGAME (so after selecting campaign)


Marduk
 Share

Recommended Posts

Hi People.

I've read most of the topics here, but I didn't encounter exactly the same problem I've got.

I Installed the game (using the fix) and updated to v. 1.09 (after 1.04 just didn't work).

Now I can launch the game, it starts properly. I select "Single Player" -> "Campaign" -> HOUSE. No matter what house I select: My game freezes when I'm moving mouse when mentat talks. So: Mission loads, mentat talks (I don't do anything, else it freezes), Mentat stops talking, I can play, Mentat says: "New units arrived" and when I'm still moving the mouse while he says it, the game locks up. My computer doesn't react to CTRL+ALT+DEL or AL+F4 or anything else. I can only reboot. Sound (music) continues (Mentat stops half-way a sentence), but screen freezes. It's not my System Config (c.q. Hardware). I'm using windows XP SP2 PRO without NAV or anything like it.

Game can't be played this way... Plz. Help.

(P.S. Problem is right like this, plz. forgive spelling / grammar-mistakes, half-drunk while writing :D)

Link to comment
Share on other sites

please attach dxdiag.

Also, have you got the latest drivers for all your hardware ?

Have you tried reinstalling it ? Try disabling sound card (Emp will work wihout) and see if it still crashes (doesnt work if you disable graphics card  ;)). Let me know how it goes !

Link to comment
Share on other sites

  • 7 months later...

I have the same situation Marduk. I had the problem with '98 and now I have it with xp pro service pack 2 on a different pc.  The only constant between the 2 setups are the 4 disks.  Oh ya and me. hehehe.  I wish I could find the answer.  Now I haven't as of yet installed any patches to the original install from the install disk so I may try that but from what I'm reading that probably wont solve this problem.  ???

Link to comment
Share on other sites

  That was one of the first things I did.  Turn down graphics, turn off shadows..  As well as exit firewall and AVG.  This new pc has only the basics on it as far as what is on the hard drive.  But what gets me;  the symtoms are the same on two different systems.  '98 and a Pentium 3 850 Mhz 512 133 RAM 40 gig HD.  7200 Radeaon 32mg vidio card and sound blaster audio card. 

  Now a Pentium 4  1.2 Gig Mhz  512  333 RAM 200 Gig HD.  Useing motherboard video and audio.  Exact same conditions.  Maybe it's the install disk?  It looks great.  Is their a test to tell if the install disk is Ok?

Link to comment
Share on other sites

I did download and install the latest patch 1.09 I think it was from the ea/ww site.  The patch didn't do a thing for me when I was running '98 but now that I've changed to XP Pro it seems like my locking up issues are not as frequent.  All three house disks now play through a mission or two before they lock up.  Last night the mouse would lock up on me solid but the game continued to play right along.  It was time to get some rest anyway so I just turned off the pc.  Ctrl, Alt, Dele..  wont close program when it locks up.  I just finished reading that 54 page thread on locking up from 2001/02.  Boy what a thread.  I came away with a couple of ideas I'm going to try out tonight if I have time.  But if someone has another bit of advice/ solution I'm all ears as is Marduk I'm sure.

Link to comment
Share on other sites

It seems like the locking-up / freezing problem is getting better every time the game is started.  Last night 3 hours of run time and not a freeze.  Thank you Re-erjin999  for helping out, even though your from England. :D  The 54 page thread on locking up was a great read as well.  Heck I even went and voted at the EA site for the resurrection or sequel of EBFD.  That makes 81% yes.  Sorry Marduk I didn't come up with anything concrete for your system but than again it's been awhile since you checked into this post. ;)

Link to comment
Share on other sites

When I was on Windows ME I had a wireless mouse that if I moved too quickly (dual-clicking) trying to rotate 3D view the game would freeze. Fixed by "learning" to move mouse slower...until I forgot a hour or so later.

The other problem was with motherboard based audio - load first campaign, voice would stutter and then game would freeze or crash - fixed by re-installing latest audio driver (got changed when I loaded some other new drivers somehow).

Fix to all this was Windows XP Upgrade, same old FAT32 format but now can run with Anti-virius, internet and hi-res graphics all on. I did though re-install the audio driver again at time of upgrade...so if you get problems again I would suggest you re-install your audio and keep your graphic down as 32MB gfx card is close to minimum spec.

Link to comment
Share on other sites

  • 1 month later...

Hi...I've gone though every page of every forum that had anything to do with Emperor Freezing the sustem mid game on either campaign or skirmish mode...I have tried everything in these post and have to ask...Has anyone finally resolved this issue?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...