Jump to content

Running Emperor from a CD


erjin999
 Share

Recommended Posts

Hehe. Is it possible to run emperor from a CD ? I mean to copy the contents of my Emperor folder on my HD onto a CD so I can play at another computer without having to install it. I have copied the relevant part of the registry as well (HKEY_LOCAL_MACHINESOFTWAREWestwoodEmperor), so it can be put on to the target computer.

So far, whenever I try to run the game on my computer at home where it is installed (E:program filesemperor) it runs seemingly from the CD (it never usaually jerks like that ! 8)) but now for the first time I have tried it on another computer and no joy. I have even copied it to the target computer (NOT what I would ideally like to do) with no luck.

I should mention that the CD drive on the other computer is also E drive. I did not preserve the same directory structure, i.e. E:program filesgamesemperor was copied to CD-ROM:

I get the black screen as thought the game is aobut to start, then back to desktop.

Any ideas welcome. Also, if Mr Moderators think this should be in dune editing, then please move it for me, I am a little unsure where it should be.

Thanks

Link to comment
Share on other sites

Maybe if you moved the installed data to a disc, used the installfix on the exes on the disk/a crack, then edited the registry to point towards the CD for the install location it should work.

I bet the computer you're trying to play it on has issues besides this one though.  :-

Emperor is a pain sometimes...

Link to comment
Share on other sites

Thanks for the reply Apo, just talking about it might make me think of something...

I have Install fixes installed, No-CD patch. Just copied the directory and registry onto cd.

I will persist...

If I crack this, I will let you all know. Meanwhile, any more ideas will be much appreciated.

i agree Apo, about emp being a "funny ol' game"

Link to comment
Share on other sites

it should be possible, although it might be difficult to accomplish.

Generally what you need to run any programm without installing it is the registry keys, the DLL files [ and mayby some otheres ] and the data files.

Edit all registry entries to the alternate location, and copy the needed DLL/SYS files to the Windows directory or where ever the programm looks for them. Just using the CD for the data file might not work, keep in mind that they get unpacked during installation, and as such are in non-usable state on the CD. You will have to have a place for the unpacked data files.

the easiest thing to do is just share the emperor directory on another PC, alter the registry things and copy a few of the needed DLL/SYS files to the other computer.

And just as warning. .. .the EULA of Dune Emperor prohibits you to install or use it one more then one PC I thought. So make shure we don't need to lock this topic........ ;)

Link to comment
Share on other sites

First off, i like the way you spell "shure" Gryph...hehe 8)

Right. Well, I do own the original CDs and have actually purchased this game for 3 other people so I could play with them online with their own serials. I am not attempting to do anything dodgy, except maybe play @ work after everyones gone, less disturbance from family !

I have not tried to copy from the CDs, so all files should be unpacked, in a useable state. I agree with Ap0 abouth this probably (he says definately ! ???) being a registry problem. I think it may be the registering of the WOLAPI.dll's or something related to the Shared Internet Components...as thats where it decides to either try to load, or not even bother to try to load when I am re-inserting the registry.

Here is what I have done:

1 Installed at home.

2 copied installed game onto CD

3 copied Registry to CD

4 Gone to target computer

5 Inserted registry into target computer

6 run game. I get blank screen then it fails (obviously you might say, but some things are that easy !)

7 Changed registry to point to correct drive and path

8 Rerun game, now it does not even try to go to black screen which it does just before loading. I get the Windows pointer become an egg timer for a split scecond before Emperor.exe exits.

9 Gone through registry and changed entries manually to correct path line at a time and check to see if it would go to black screen. Found that at the line that reads [HKEY_LMSOFTWAREWestwoodWOLAPI]

"InstallPath"="C:Program FilesEmperorShared Internet ComponentsWOLAPI.DLL" changing this to the correct path would make it as described in 8 above.

10 Entered a fake path, and it does as in point 6 above.

Also, I had registered the dlls as best I could. regsvr32 pathwolapi.dll

Concluded that it has something to do with shared internet components. Could be wrong, but will bring in CDs to install just that part of it to test. Will update here in a bit...

Sorry about the extra long post ! :-X

Link to comment
Share on other sites

Whenever I do stuff like this I use Norton Cleansweep. It records all files being placed on the HD and all changes made to present files. Well, mayby not all of them, but most of them anyway.

wasn't it Scotty who ones mention : use the right tools for the right job .. . ?

After that it's just a matter of alteration. Keep in mind that some registry entries need an etxtra set of slashes to function.

not servershareemp.dll

but servershareemp.dll

Link to comment
Share on other sites

Having spoken to my brother who says that I may not have the complete set of registry entries as he HAS used a monitoring proggie to check, I will go and hunt down the rest of them.

Gryph, I think the normal path would be a single slash "" and yes, the .reg files should have an extra one to make it two, ""....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...