Jump to content
Woodruff

No Cars Available for Engines

Recommended Posts

Hi!  I've just started playing Railroad Tycoon II a lot, and I've gone in and created my own map in the editor set to start in 1830.

However, when I try to play this map, the only "cars" that the industries show as transporting their goods are "Industrial", "Commercial", and "Residential" and within the engine-path screen, there are no cars for me to use.

For example, if I want to transport cattle, there is no cattle car, and no passenger or mail cars, even.  No cars at all.

What have I screwed up?
 

Share this post


Link to post
Share on other sites

I finally figured it out - I'm going to post it here in case someone else comes up with the same problem.  In the options area, you have to have "Menta" or "Mesta" or whatever unchecked.

Share this post


Link to post
Share on other sites

Yeah, you stumbled into "Metra", which is for city-scale maps with commuters and local freight. I'm glad you found your way out of that.

Post again if you run into any more trouble.

Share this post


Link to post
Share on other sites

Ok, same map - now that I've started playing it...I have the map start in 1830.  Yet immediately, the map has GeoCore map items on it, and they're as common as anything else is.  But shouldn't there be some sort of a "start using this item" date associated with it, since it seems like it would be a pretty late-stage item in the game.  By the same token, I have been playing for a while on this map, and ZERO steel mills, dairy production (I have milk production), or canneries have appeared.  Meanwhile, my factories are no longer accepting iron (presumably because it would be going to the steel mills), so I have nothing at all to do with my iron sites.

I'm confused as to why this has happened, because they're not disabled anywhere in any of my settings (regional or city).

 

 

Share this post


Link to post
Share on other sites

I don't see them disabled in any of my regional or city settings, and they're not disabled in the "INDUSTRY WEIGHTINGS" under the MAP OPTIONS either.  Is there another place to look?

Also, where would I look to see why the GeoCore is showing up immediately in 1830 instead of later in the life of the map?

Share this post


Link to post
Share on other sites
12 hours ago, Woodruff said:

Is there another place to look?

Did you give them any weight in any of your towns and econ regions?

I've never seen a Geocore. Should they even show up on a non-Metra map? You should go into the allowed industries list in the editor and just turn them off. Then start a new game on the map.

Share this post


Link to post
Share on other sites

The Geocore Industry has a start date of 1800, which is why it pops up so early. The developers obviously intended for it just to be used in the campaigns, or to be manually placed down in specific locations. Unfortunately, you can't change the start date of industry in-game without editing the exe file.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...