Jump to content

Emperor on XP


Recommended Posts


I followed the official patch instructions, and the game installed, only when i copy Emperor.exe to the install directory (currently not one already there) and run it, it says "Run the game from its install directory", and when i run game.exe, it does nothing at all, tried from the CD's autorun too (does the same, but mehh)

I then installed the 1.09 patch, no change. Installed a No-Cd 'crack', no change.

Can anyone help?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...