Jump to content

Emperor Graphics Problem


Hunter434
 Share

Recommended Posts

Okay Here I Go.

I Bought Emperor Battle For Dune Back When It First Came Out. I Had a Pretty Diecent Computer For Back Then, Windows 98SE 8Mb Video Card, Pentium 3 550Mhz and It Worked Great.  Believe it or not I only had a 8Mb Video Card.(Savage 3) And It ran just fine. I loved Playing This game so Much. Then we Got Rid of that computer and bought two new ones.

Now I am Running Xp Pro On Both of My computers and these are the specs.

High Performace Computer  ;)

AMD Atholon 64 X2 3800+ (2.0 Gigs)

Nvidia GeForce 6100 128Mb Video Card (All Drivers Are up todate) Running Directx 9.0c

1 gig of Memory

and On-board sound.

Second Crappy Computer but better than my first one

Intel Pentium 3 800Mhz

Crappy 8Mb Video Card Same One As Before

512Mb Ram

Onboard Sound

Alright Now Thats out of the way this is the problem I am Having.  I installed the game just fine, no problems no nothing.  Then I start the game from the cd drive and the westwood and ea games logo apears and they do there little thing.  The Begining movie plays and everything looks great. Then when the menu loads it is all F@*#ed up hardcore. Every inch of the screen is mixed colors of red, blue, green, yellow, and you cant even make anything out.  I cant get to the video options to even try anything with the settings.  Now I have posted this in other websites forums and I have looked around in here and no one knows anything or has had this problem. I dont think that my 8mb video card has anything to do with it because i get the excat same problem on my new machine.  I know its not my drivers because i had old ones and it didnt work so i upgraded to the newest ones and still no luck. I have inclosed an attached picture of my screen durning the menu so everyoine can see how messed up this is.  I also included a copy of my dxdiag log file. And by the looks of it no one is going to be able to help me.

These are all the possible things i have tried

1.) Drivers for both machines upgraded and installed previous ones.

2.) Ran a older version of dirct x 8.0, 9.0, 9.0a, 9.0c, 9.0b

3.) Windows compadablity in 98, 2000, 95, nt, all with differnt 256 color settings, and other stuff 640X480

4.) Reinstalling it (Game) multiple times

5.) Tried different video cards

7.) Even bought a new copy of the game and still it's all gay

Also My cds are in perfect condition no scrathces or anything like that.

I think its some stupid Xp thing because it worked fine on my old piece of crap computer that didnt even meet the requirements

Any Help would be great but for some reason I dont think I am goiong to get very far

[attachment deleted by Gobalopper]

Link to comment
Share on other sites

  • 2 weeks later...

Hunter I have had my share of this game crashing, freezing, locking up etc., but have never seen my screen do what you show.  I had 98 and a 32 meg radeon card and when I first started playing in 01 it ran great, than as time went on I  had problems.  I up-dated to XP pro, service pack 2 and had minor lock ups and a few freezes.  I bought a 256 meg Radeon card and have no problems to report.  XP didn't make my problems worse but better.  Could this be a monitor related problem?  Just throwing that out there.

P.S.  Also I noticed that when I up-dated my sound card drivers, SB Live. Alot of what I thought were graphic card problems got better.

Link to comment
Share on other sites

Hunter, here is a post by JulesG,

When I was on Windows ME I had a wireless mouse that if I moved too quickly (dual-clicking) trying to rotate 3D view the game would freeze. Fixed by "learning" to move mouse slower...until I forgot a hour or so later.

The other problem was with motherboard based audio - load first campaign, voice would stutter and then game would freeze or crash - fixed by re-installing latest audio driver (got changed when I loaded some other new drivers somehow).

Fix to all this was Windows XP Upgrade, same old FAT32 format but now can run with Anti-virius, internet and hi-res graphics all on. I did though re-install the audio driver again at time of upgrade...so if you get problems again I would suggest you re-install your audio and keep your graphic down as 32MB gfx card is close to minimum spec.

Anything?

Link to comment
Share on other sites

  • 1 month later...

heyo, didn't want to start an extra topic for this: I "installed" the patch which allows you to zoom out/zoom in farther and makes the map white. the patch is mentioned by gunwounds in his sticky thread. the zoom out is great, very great... but it appears I now have some gfx problems. buildings & rocks seem to flicker every once in a while. any ideas why? is this normal if you use the patch?

Link to comment
Share on other sites

Re, disable the patch, its easy enough (simply undo the installation, move the folders out of the directory they are in or rename them....).

That should tell you straight away if the problem is the patch or not. Once moved away, if the patch is the culprit, it will start to work well (the game, that is). If it doesnt work well, its not the patch.

Link to comment
Share on other sites

  • 1 month later...

I have the exact same problem. Somehow I manged to get to the atreides campaign screen, thought it would work out if I opened a game but it gave an error and closed down. What suggestion are you making, reinstall audio drive?

Nothing I tried helps, and my comp is a good comp I dunno the properties but I know my lesser comp played it perfectly.

Link to comment
Share on other sites

Good idea. If not I will find them in the registry for you, and you can change them from there.

Ok, found them. Go here for the graphics options:- HKEY_LOCAL_MACHINESOFTWAREWestwoodEmperorOptionsGraphics. Find MultiTexture and HardwareTL and make shure both are set to 0.

Load the game and pray.

Also, try lowering DX acccelaration by going to Display Properties (Right click on Desktop > Properties) then Settings tab > Advanced button. Go to troubleshooting. Lower the slider slightly (I think if you go more then 2 or 3 from the right it will not load anymore !).

Post back your results.

Link to comment
Share on other sites

Nope, no change at all but I made a shocking discovery.

It seem like he guy who sold me the cd downloaded it from a torrent! I was trying to find anything that could cure my problem and I found this folder torrent with the file "Emperor - Battle For DUNE `mininova.org'" maybe because it is pirated? I am too scared please help me! I will install it in my crappy comp and see if anything comes out.

Link to comment
Share on other sites

That damn thing wont work on any computer. I guess I'm screwed! But please do help!

EDIT! I fixed it! You just have to change the name of the file from EMPEROR.EXE in the cd to Emperor Battle for Dune_EZ.exe, GO_EZ.EXE to go_ez.exe, SECDRV.SYS to secdrv.sys, DRVMGT.DLL to drvmgt.dll and EN_US_EA.HLP to en_us_ea.hlp CapitalS WERE important.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...