Jump to content

Launches only in windowed mode, reboots system


Recommended Posts


I've searched through here, but haven't found anything that quite matches what I'm seeing. Here's the gist of it:

Running XP Pro, SP2. Had to install using the fixed install. Try to run the game and it hangs. Never loads, never even leaves the desktop. I get the icon at the bottom, and the process shows up as not responding in the task manager. I kill it, use -W to try windowed mode. Starts right up. Go into Skirmish to test things out and it reboots my system without an error, or entry in the event log. Ok. Try -W -s . Now, instead of rebooting, I get a generic exception in game.exe . Try patching, 108 and 109, and neither makes much difference. Try the no CD executable for 109, and it loads right up without being in windowed mode, but is otherwise the same. The crashes/reboots occur either right as I'm entering the battlefield or a couple of minutes into playing the skirmish. I haven't tried any other modes yet.

Steps I've taken:

Uninstalled and reinstalled all of my drivers.

Reapplied SP2.

Reinstalled Emperor many times.

Uninstalled Kaspersky Anti Virus, just in case.


Athlon 3200+

256MBx2 Mushkin 222 RAM

DFI Ultra Infinity mobo.

WD Hard drives

Fx5600 Video Card

Envy24 Sound Card

3Com Nic.

380 Watt Enermax Whisper PSU

Background Processes:




















Also attached is my Dxdiag info.

Thanks to anyone who as any advice. I'm baffled.

[attachment archived by Gobalopper]

Link to comment
Share on other sites

Ok, small update.

Running the game in Win 95 compatibility mode with the sound disabled let's me play for about 8 minutes before I get a crash in game.exe . With the sound on it behaves the same. Without the compatibility mode on, disabling sound doesn't alter the time to crash in any appreicable way, but at least my computer isn't forced to reboot.

Link to comment
Share on other sites

Another little update. With both of my sound devices disable, I use that Envy24 card for my speakers and the Nvidia onboard for my headset, the game seems to run fine, but with either one enabled it crashes. This is regardless of whether I have the -s or not. The only difference that makes is that without it my computer reboots, and with it I get a crash to desktop in game.exe .

Link to comment
Share on other sites

So you think its a sound issue ? Can you play it perfectly without the sound devices enabled ?

Would be simply a matter of getting your hands on an alternative sound card to test...

Seems like you are doing all the right things to work it out yourself :P.

Link to comment
Share on other sites


Thanks for the replies. It's been very frustrating. It does seem to be a sound issue, though I'll be testing that further a little later today. As it is, with any sound device enabled, I can only play for about three minutes or so, max, before crashing. With both devices disabled I've run it for 15 minutes, so far, but had to take care of other things, so I couldn't try a full game.

I've found nothing mentioning Emperor in any logs, just the generic fault in game.exe . My drivers and config all seem on the level. It's really weird, to me, that it doesn't matter which sound device is being used. Other games, notably Warhammer 40k: Dawn of War and Guild Wars, function just fine. On this same hardware, but a format and reinstall of XP ago, all of the Mechwarrior 4 games, and Il-2 Sturmovik also ran fine, so I don't believe any hardware faults are present.

A couple things I'll be trying tonight is running the game in vmware and virtual pc, using 98SE, just to see, as well as leaving a sound device enabled in XP, but dropping the hardware acceleration and using the -s in Emperor. Does anyone know, definitively, if Emperor will make calls to DirectSound even when the -s is used? I can only assume it does, given that the game still crashes with it, but I'm uncertain.

If anyone can suggest anything, I'll try it.


Link to comment
Share on other sites

Okie dokie. Just finished playing for about an hour and fifteen minutes without any trouble at all. With my sound disabled. Couldn't quite get it to run in vmware or virtual pc, mostly due the deep directx funkiness involved with doing that.

So, any thoughts? I'd really rather not have to play with no sound, it dramatically diminishes the experience.

Link to comment
Share on other sites

Hot buttery goodness is mine! Well, so far so good anyway. It was the damndest thing. In my madness I thought perhaps it was having trouble with processing the sound files in the bag archives, so I extracted them and proceeded to play them. Since I'd reinstalled XP a few weeks ago, I hadn't ever played any media files, and Windows Media Player hadn't been setup. So I ran through the wizard, played some of the w files, and everything seemed ok with them, but I was struck by an odd idea. Could WMP have any impact on this?? So I tried it again, still with just one soundcard, and using -s, and while it still crashed I noticed two important things. One, it ran very smoothly. It wasn't bad before, but now it was running along brilliantly. Two, the crash didn't occur for until after about 20 minutes of game time. I was intrigued. Promptly I went to windows update and nabbed every media related update I could lay virtual hands to and made it mine. A couple of restarts later I tried Emperor again, same settings as above. An hour and half later I was crushed by the filthy Harkonnen... but no crash. Emboldened I removed the -s. I've played two skirmishes since then. I can't tell you the time involved because I became deeply engrossed. There's something to be said to coming back to a great game after a two or three year break. Anyway, I hope this helps others in my extremely unlikely situation.

Later everyone!

Link to comment
Share on other sites

Always glad to hear a story with a happy ending. I personally didnt realise that WMP could mess up emperor, I thought it was bad enough it would be messed up itself.

Have fun with Emp, and thanks for leting us know how it went, maybe this might help others.

...maybe we'll see you online  ;)  (Had to put that in there...)

Link to comment
Share on other sites

Shai-Hulud willing I'll have time to play online. Unfortunate that my long weekend free time was mostly spent on tracking this down. I mean, wow, that was heavy. I fix computers for a living, I have a pretty solid grasp on how OS components work, but I can't even begin to fathom what was going on there.

Oh well. My roommate was having trouble with icons not showing up in his systray, and after some research I found a suggestion to turn off the UPnP interface. Not the service mind you, just the buttons, and lo, it was fixed. At least my issue had a theme to it, this was like changing a light bulb to fix your dryer.

Anyway, hopefully I'll see you online as well. First I've got to get back up to speed, since the AI currently trods all over my tender parts, leaving me to imagine the horrors that would be visited upon me in a real match.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...