Jump to content

can't enjoy D2K Gruntmods ... Can't start anything


Recommended Posts

Hey guys,

i try to get this running on my windows 10, 64bit system
i got a nvidia geforce 2080 rtx, 1st monitor 240hz 1920:1080p res, 2nd Monitor 144hz but set to 60hz 1920:1080p res
both monitors max res is full hd and are set so.

i installed gruntmode + windows 10 hotfix. i tried different settings and compabilities, but not every possible combination.

depending on what i changed, while clicking "launch campaign", i either get the error:"This video card does not support the required modes...."

or the application, before crashing, tries to start while changing resolution and showing black scrrens on my 1st monitor.


I have no clue what steps i have to do or what is the right path do get it going. is there any step by step guide or manual what things i have to change or check?!?!

Thanks in advance guys


Link to comment
Share on other sites

Hi guys I have a similar issue to  burig I did the up date on my machine a windows 10 and before the update everything was fine but since the update I get an error message. (set display mode returned-214767263 (gGameTicks=0). What the heck does this mean and how do I fix the problem please.


Thanks in advance I love the game and always have since buying it way back when.

Link to comment
Share on other sites

On 7/3/2021 at 9:15 AM, burig said:



6 hours ago, willhawk said:


Hey guys. Some of us have been chatting about what this might be in other channels, but none of us know precisely, so apologies for the late reply. :P

I have personal experience with some folks who have had trouble launching through the normal exe, so here are some recommendations. First, pick up the new Mission Launcher from this thread:

Also pick up the latest version of the exe, community patched by our very own Klofkac:

I'm using both of these on Windows 10. Working a-okay. After you have both of those, fiddle with the video settings in the dune 2000 config exe in your main d2k directory. The same directory where you put all that other stuff. If yours doesn't work, I have a different version with more options, so you may want to try this instead:

Even if you don't use windowed mode, you may still want to enable  DxWnd and GDI Mode. That seems to facilitate alt-tabbing and some other modern features. The video settings seem to most often be the culprit of things not working properly, and also trying to run through the normal exe. Try launching missions through that Mission Launcher instead, especially after fiddling with the settings. And hopefully that sorts everything.

Good luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...