Jump to content
Sign in to follow this  
MrFlibble

Critical bug in v1.07 (AI ignores units)?

Recommended Posts

Recently I was notified by Cm_blast and a user in another forum of a bug that was apparently introduced in v1.07, but I never really noticed it myself (granted, I spent a lot more time playing v1.0 though).

It appears that under certain circumstances, the AI will ignore the player's units. This is how Cm_blast describes it:

Quote

This happen on repaired units.

You have your siege tank being attacked, the carryall pick up, go into the repair pad; then I don't know if the repair pad being covered by buildings/walls or not affects, but after the carryall drop the unit at his original position that unit is no longer under attack by enemy turrets or other units.

Only if you siege tank attack an enemy unit this will return fire.

Sometime later I discussed this with mrXyz of the Old-games.RU forums, who independently reported what appears to be the same bug. I told him about the supposed dependency on the repair yard but he says he cannot reproduce the behaviour this way. According to mrXyz, the bug is a lot more random and sometimes affects several units at once, with no clear cause for this.

I don't remember that this kind of buggy behaviour was ever discussed here, or that the OpenDUNE or Dune Dynasty developers mentioned it. At present I'm in no position to test the game, so if anyone can shed further light on the problem that would be very helpful!

 

Share this post


Link to post
Share on other sites
1 hour ago, MrFlibble said:

Recently I was notified by Cm_blast and a user in another forum of a bug that was apparently introduced in v1.07, but I never really noticed it myself (granted, I spent a lot more time playing v1.0 though).

It appears that under certain circumstances, the AI will ignore the player's units. This is how Cm_blast describes it:

I Played the whole Harkonnen campaign using the instructions you gave to me (getting the v1.00 and doing the patch to 1.07 manually); on 1 map (first map you get the Devs) I covered the repair pad with walls and waited until I have the chance to try if this happened.

I have the video recorded in front on me, so at least in this version that doesn't happen. My Siege tank went to the repair pad, the carryall bring it to the position he was grabbed; I deliberately select it to attack the first to an enemy turret; my tank uncovered 2 enemy units; which his first target was that siege tank and not the other vehicles that were only 3-4 tiles away.

Even the turret that I attacked turn and started to fight back to my Siege Tank.

So at least in the US 1.07 patcher from v1.00 that thing doesn't happen (or, maybe not always). I can't tell for sure if units being repaired the "normal" way (no walls or even manually send) may be affected; I've using the repair pad for all missins and repairing tanks that are at 80% HP and I didn't notice anything wrong.

Just want to said that I usually play the game in spanish, and I download the game from a "random" site "or even my own CD; which who knows from where I pick up the game". But I remember playing maps with several units being repaired that later are completely ignored by turrets; I don't ever remember if that game was modded with the team bug fixed (because I totally remember playing the game at least once with enemies attacking in teams), so it's hard to know.

However, I encounter a new bug; it's the very first time I ever encounter that bug.

It was during map 4 (tanks); I attacked the enemy harvester and was trying to destroy it before reach the ref with the 100% full of spice. The harvester was loosing HP and, at the very last step, my units shoot the "final blow", but at the same time the harvester reach the destiny:

https://prnt.sc/mp4b64
At that same moment the harv already took 1 shoot from the quad, and the trooper was the first shoot; the second seems to impact in the building itself, but the first just impact at almost the same time between the harv it's a unit and become 1 with the building.

Because of that, this happens.
https://prnt.sc/mp4cj9

That harvester not only didn't move when was release but, by the time I manage to reach it, he was an unkillable unit. Good thing this game only ask for building and not units, if not I would need to repeat the whole mission.

Share this post


Link to post
Share on other sites
On 2/23/2019 at 8:04 PM, Cm_blast said:

That harvester not only didn't move when was release but, by the time I manage to reach it, he was an unkillable unit. Good thing this game only ask for building and not units, if not I would need to repeat the whole mission.

This is very old bug from v 1.0 :)

I memory it in 1994-1995)))).

 

example for bug no attack units....
https://www.youtube.com/results?search_query=dune+2+atreides

 

many videos contain this bug.

https://youtu.be/W4niErN-hrQ?t=1425
 

all sonics tanks in video - get invisible for enemy in moment. units no repair and etc.

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...