Jump to content

host file problem


Voodoo Daddy
 Share

Recommended Posts

Hi all, I hope someone can help me with this. I can't get the host file to change on my laptop. If I try to use the XWIS tool to update the host file, when I click the set button I get a warning box with a red X in it that says "host file could not be updated" I checked Nunu's post on how to get online, and tried to update the host file manually, but that didn't work either, I got the same message. Then I got the Idea to check the properties of the "etc" folder that the host files are in. It had a check mark in the "read only" box. So I unchecked it, hit apply and ok, then re-booted the machine. when I went back in to the folder it was still read only. And yes, I am the system administrator. I think the host file won't update because it is "stuck" as read only. Do you think I am right or is it somethiong else? Any ideas on how to get the change to the read only attribute to do what I want? And it's not just changing to ra's address, It won't change to any other address.

Thanks, Voodoo

Link to comment
Share on other sites

Have you got Spybot Search and Destroy ? Or any other "good" program ? Have you ever had them ? I know S&D can lock your hosts file for you.

Try going to the actual file (HOSTS), right click on it (not the "etc" folder) and then take off the Read Only tick mark.

Hit "Apply" and "OK" and there should be no need to reboot.

If that fails, open the file, click File > Save As in notepad and then save it as VOODOODAMAN, then close it, delete HOSTS file, then rename VOODOODAMAN to HOSTS. Basically replacing it with a copy that isnt being naughty.

Let us know how you get on.

Link to comment
Share on other sites

OK here's what I tried.

Have you got Spybot Search and Destroy ? Or any other "good" program ? Have you ever had them ? I know S&D can lock your hosts file for you.

Didn't have Spybot on this machine, just Ad-Aware.

Try going to the actual file (HOSTS), right click on it (not the "etc" folder) and then take off the Read Only tick mark.

Hit "Apply" and "OK" and there should be no need to reboot.

The actual hosts file is not read only. The tick box is empty. But still unable to change it. and the XWIS tool still doesn't work.

If that fails, open the file, click File > Save As in notepad and then save it as VOODOODAMAN, then close it, delete HOSTS file, then rename VOODOODAMAN to HOSTS. Basically replacing it with a copy that isn't being naughty.

Tried this, did the save as Voodoo, then tried to delete the original, It wouldn't let me.

"Cannot delete Hosts, access is denied.  Make sure the disk is not full or write protected,and that the file is not currently in use."

I also tried going up a few levels to the system32 folder and remove the read only check from that one and all sub-folders and files. After doing that, the "Drivers" and the "etc" folders are still read only. But not the hosts file.

Got any idea on what else could be using the file? Perhaps it is considered by Windows to be "in use"? I even tried disabling the LAN radio on my laptop before changing the settings so there was no way the computer could think it was on-line.

Link to comment
Share on other sites

Sheesh, nice one ! You tend to get the interesting ones, dont you ? :P

Try safe mode to mostly eliminate the chances of the file being in use. As for the other option, it may be that you dont have permissions to the file.

First verify you have ntfs file system (FAT32 doesnt support permissions) by goign to My Computer (same as explorer) and right clicking on the C: drive, then choose Properties. Just about the third item down should tell you whether it is FAT32 or NTFS.

If it is NTFS, then close that small window down, and back on the C: drive, browse to the folder containing the HOSTS file. Right click on the folder and choose Sharing and Security. If it isnt there, you will need to disable Simple File Sharing under the Tools menu, in the Folder Options under View tab. Its the very last item.

Back on the folder, right click and choose Properties, then Security. Make shure "Everyone" is listed as one of the users that can write to the folder, in fact, give "everyone" all permissions. If "everyone" isnt listed, add "everyone". Let us know if that makes any difference or not.

Link to comment
Share on other sites

OK, my file system is NTFS.

If it is NTFS, then close that small window down, and back on the C: drive, browse to the folder containing the HOSTS file. Right click on the folder and choose Sharing and Security. If it isnt there, you will need to disable Simple File Sharing under the Tools menu, in the Folder Options under View tab. Its the very last item.

Back on the folder, right click and choose Properties, then Security. Make shure "Everyone" is listed as one of the users that can write to the folder, in fact, give "everyone" all permissions. If "everyone" isnt listed, add "everyone". Let us know if that makes any difference or not.

When i right clicked on the ETC. folder, sharing and secutity was in the list, but there was no "everyone" option. Just a dialogue box telling me that to share it, I should drag it to the Shared Documents folder. Were you thinking perhaps that I had XP Pro? Also there was no Simple file sharing in the folder options, the last item in the view tab was "show pop up descriptions for folder and desk top items".

I am going to reboot into safe mode and see if I can change it there, I will let you know.

Link to comment
Share on other sites

ALLRIGHTY THEN..... I CAN change it in the Safe mode. But what could be using the file otherwise?

Here is a copy of the Hosts file, Do you see anything unusual? Do you have any idea what could of screwed up my permissions?

# Copyright © 1993-1999 Microsoft Corp.

#

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

#

# This file contains the mappings of IP addresses to host names. Each

# entry should be kept on an individual line. The IP address should

# be placed in the first column followed by the corresponding host name.

# The IP address and the host name should be separated by at least one

# space.

#

# Additionally, comments (such as these) may be inserted on individual

# lines or following the machine name denoted by a '#' symbol.

#

# For example:

#

#      102.54.94.97    rhino.acme.com          # source server

#      38.25.63.10    x.acme.com              # x client host

127.0.0.1      localhost

195.13.163.187 irc.westwood.com

72.17.137.93 servserv.westwood.com

Link to comment
Share on other sites

That is as bog standard as it can be with Emp installed (or should I say XWIS used :P).

Could be another proggy protecting you from malicious changes, perhaps Ad-aware...

I dont think it is a bad thing in itself, that it is write protected, just a bad thing that you are not aware how it is so you can make changes when you want.

Next time, or whenever you get a chance, disable ad-aware, or look for the option to protect your HOSTS file.

Either way, good stuff  ;D.

Link to comment
Share on other sites

Nunu do you, or does anyone know if there is a way to see, or a program to use, that can tell you what program is using a file? For example with Admin. services you can look and see what services need a particular service to run, and what services that a particular service needs to run. Is the same info available for files somehow?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...