Jump to content
Sign in to follow this  
Picard

Black borders, small screen

Recommended Posts

Hello,

I have the following problem. When I want to play Dune 2000 in lower resolutions, i always have big black borders top, bottom and at the sides and the screen is relatively small, not 1:1 let us say 640x400 but the monitor scales the game in a small frame. I had the same problem with the origin version of Red Alert but when i have installed the CnC.net patch the wonder is that the monitor scales the game in proper relation. It looks like this now https://www.youtube.com/watch?v=hxVIREh915A Only small borders at the sides but in the Gruntmods Edition it simply does not work with the same graphics settings. Does anyone has an advice?

Share this post


Link to post
Share on other sites
On 1/17/2019 at 1:35 PM, Picard said:

I have the following problem. When I want to play Dune 2000 in lower resolutions, i always have big black borders top, bottom and at the sides and the screen is relatively small, not 1:1 let us say 640x400 but the monitor scales the game in a small frame. I had the same problem with the origin version of Red Alert but when i have installed the CnC.net patch the wonder is that the monitor scales the game in proper relation. It looks like this now https://www.youtube.com/watch?v=hxVIREh915A Only small borders at the sides but in the Gruntmods Edition it simply does not work with the same graphics settings. Does anyone has an advice?

Something similar happens to me on Dune 2000 (not small frame, but the black borders). Try every single option and/or combination using the "Dune2000Config" that I assume you have on the game's main folder; if nothing seems to work you may try this older version:
Dune2000Config.rar  <-- this is the 2016 version. It's the one I am currently using.

Before moving my file into your folder, you may rename the one you have there, so you can keep both.

Has a few different options, but at least on my case after executing this one I can play the game at 640x400 filling the whole monitor with no black borders.

Edited by Cm_blast

Share this post


Link to post
Share on other sites

Thank you for the answer, seems you have the exact same tool as me with the settings that are standard at grundmods: backbuffer on, maxwindow deactivated, improved fps limiter, no direct draw, high dpi on, dxwind off. Right?

Well i copied both files into dune2000 order with no effect. I will still try some combinations. The thing is CnCnet patch changes Dekstop Resolution before starting the game, so Red Alert will be depicted in full screen with just small black borders. Other games like Dune 2 in DosBox can also not be shown in Fullscreen.

 

Edited by Picard

Share this post


Link to post
Share on other sites
19 minutes ago, Picard said:

Thank you for the answer, seems you have the exact same tool as me with the settings that are standard at grundmods: backbuffer on, maxwindow deactivated, improved fps limiter, no direct draw, high dpi on, dxwind off. Right?

Well i copied both files into dune2000 order with no effect. I will still try some combinations. The thing is CnCnet patch changes Dekstop Resolution before starting the game, so Red Alert will be depicted in full screen with just small black borders. Other games like Dune 2 in DosBox can also not be shown in Fullscreen.

 

Did you try the enable "DxWnd" (and the rest of the options than become available with that)?

If still, maybe you didn't have the most recent version, which I assumed you had.
Here you can download it.
https://forum.dune2k.com/topic/26661-dune-2000-106p-game-patching-bug-fixes-new-features/

I don't feel like opening again because messed a bit the visual, but I remember the first menu had the options "windown - fullscreen - extended" and a 4º one that said "no-borders" (I think).

If you didn't have that one version you may try it.

Share this post


Link to post
Share on other sites

Oh wow thanks. Well many new Options here. I just downloaded the gruntmods Edition 2 days before from the official Homepage, so i had no clue that there are newer config Options. I will try this out after playing some rounds Starcraft 2. I like when old games are big like SC, could never zoom out in 1920x1080 like some are doing in Dune.

Share this post


Link to post
Share on other sites

Awesome thanks, the config app looks now like on cnc net. The ironic thing is that i can play with correct proportions only when choosing "stretched" and in advanced options 'maintain aspect ratio', not with 'fullscreen' but it works. Thank you a lot!

Edited by Picard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×