Jump to content
FunkyFr3sh

Dune 2000 1.06p - Game patching (bug fixes, new features)

Recommended Posts

Sadly this doesn't seem to be true entirely. I upgraded to Windows 10 today (everything went smooth) but Dune2K won't zoom to full resolution anymore. If I choose windows mode @ 1280x720 I can clearly see a 1280x720 game windows but the game itself just uses the original resolution. I tried all config options and nothing changed. Any ideas?

Share this post


Link to post
Share on other sites

Sadly this doesn't seem to be true entirely. I upgraded to Windows 10 today (everything went smooth) but Dune2K won't zoom to full resolution anymore. If I choose windows mode @ 1280x720 I can clearly see a 1280x720 game windows but the game itself just uses the original resolution. I tried all config options and nothing changed. Any ideas?

Sounds more something like graphics card (driver) related. Try searching in the videocard menu for something with 'scaling' or 'fit-window' etc.

Share this post


Link to post
Share on other sites

That was the first thing that came into my mind. I checked the scaling options and everything's set to fullscreen with the correct aspect ratio...

 

The scaling problems appear to start when using DxWnd, which gives me a tiny little screen with wrong colors. When choosing GDI Mode, it looks like in the screenshot below.

 

When using no DxWnd the game freezes after the "Dune2000 Intro" just before the menu screen.

 

2nisdcm.jpg

Share this post


Link to post
Share on other sites

DxWnd+GDI mode has scaling turned off, I set it up to center instead (that's because the scaling performance was really bad with GDI mode)

 

The game starts in 640x400 (for the videos) and then switches the display mode to your chosen resolution. So it probably means the game is unable to switch the display mode and freezes

 

Can you try to change your game resolution to 640x400 (try 640x480 too) and start the game without dxwnd? This was you can prevent the game from switching resolutions

 

Another useful test would be turning off the videos, this way the game won't switch the resolution either

Share this post


Link to post
Share on other sites

DxWnd+GDI mode has scaling turned off, I set it up to center instead (that's because the scaling performance was really bad with GDI mode)

 

That can't be. I was playing like this for the past weeks. Dune2K set to 1280x720 with DxWnd+GDI on a 2560x1440 screen and everything was fullscreen :D I can even prove it to you because it still runs with these settings on my girlfriends PC.

 

I tried 640x480 without dxwnd. It played the first video and freezed. I'll try without videos.

 

EDIT:

 

Ok. Without videos and DxWnd the game starts and is playable @ all tested resolutions (640x480, 800x600, 1280x720). Though it crashes while exiting.

 

With videos the first Dune 2000 video is being displayed, after that the game swiches back to the desktop, with a black Dune 2000 screen in the upper left. I have to logoff via taskmanager to get out of it.

 

 

Could you enable scaling with GDI mode just for testing. I remember Nyerguds wrote something about bad performance in his patch and it was always ok on my machine.

Share this post


Link to post
Share on other sites

The scaling is normally only needed in window mode, with GDI it will center it to the screen when you resize the window. But I guess you are trying it in fullscreen mode? With full screen there is no scaling normally since the game switches the display mode and it will become fullscreen that way

Share this post


Link to post
Share on other sites

Now I get it. Yes, normally I am using fullscreen mode. The above screenhot has been taken while using the game fullscreen. So for some reason the game won't switch resolutions in WIndows 10 using DxWnd :/

Share this post


Link to post
Share on other sites

I guess the problem is that the game won't switch resolutions anymore at all (that's why you are freezing), but DxWnd is smart enough to notice such bugs and allows you to contiue where the vanilla game would fail :)

 

Does the game work with the movies turned off?

Share this post


Link to post
Share on other sites

Vanilla without movies works besides a crash while exiting. Being a "story gamer" that is not really a choice though :)

Share this post


Link to post
Share on other sites

I tested your new exe. The following changed:

 

- Videos are not centered anymore except when using 640x400, of course. Instead, they are in the upper left corner.

- The game freezes after the Dune 2000 logo video. No main menu, no switchting to the desktop, it just freezes.

- Game is playable with disabled movies though.

- No differences between DxWnd or no DxWnd besides:

         - Only GDI-mode prevents crashing while exiting the game

Share this post


Link to post
Share on other sites

No change regarding the mentioned issue with both exe files. Freeze with movies, no freeze without them. Awkward mouse behaviour with the original exe.

 

System used: i7 2700k @ 4.2 Ghz, GTX 780 (newest driver: 353.62), Windows 10 Pro.

Share this post


Link to post
Share on other sites

Awkward mouse behaviour with the original exe? The original doesn't allow you to disable the movies, are you sure you tested the right file? How far you get with the original one?

 

here is one more:

 

http://funkyfr3sh.cncnet.org/files/temp/test2/dune2000.exe

 

I'm out of ideas after this one, not sure if I can fix it without having windows 10 to look at my own :(

Share this post


Link to post
Share on other sites

I definitely used your original exe file. I could disable the Dune 2000 video by renaming the movie folder. I just tried this again but strangely now I can ony hear the sound. The game changes the resolution but only showes me a 4:3 desktop view. Still, I can clearly make out the Logo video and main menu sound and, with renamed movie folder, just the menu sound. 

 

Your new file achieved nothing new. 

 

If I can help in any way, just let me know. Hopefully you'll be able to test Windows 10 in the near future.

 

Regarding the awkward mouse behaviour: It was choppy, like the framerate was not consistent.

 

Oh, and thanks (!!!) for your help.

Share this post


Link to post
Share on other sites

It works...and I don't know why.

 

I tested you new file and nothing new happend. It wanted to try all options but went to my girlfriend's PC instead. She has the game still on her drive and upgraded to Windows 10 as well. Guess what: It worked. Flawlessly. With Rev 27. The one I used just before I wrote you about my problems. So I put her gamefolder on a Stick, put it on my PC and...it worked. So I put her exe file in my game folder and I still got the freezes. I checked the options and she hadn't activated single processor affinity. So I unchecked it. And it worked. Ok, I found the problem. No, I did not. I reactivated single processor affinity and....it worked again.

 

So now I am using Rev 27 on Windows 10, everything set as always (with DxWnd + GDI) and the game works. I seriously don't know why. And I am sorry for the trouble I made. But you have to believe me: It stopped working. And now it works again. And I seriously don't know why.

 

:D

 

EDIT: So now I've put your latest file into my game folder again...and it works. The videos are in the upper left corner, transition times seem to be a bit longer, but other than that it is working fine. The SAME FILE that didn't work a few minutes ago.

Share this post


Link to post
Share on other sites

well, at least you got it working now :D

 

So the game is full screen now, no more black bars on the sides?

Share this post


Link to post
Share on other sites

:D 

 

Yes, the game is fullscreen, black bars only when movies are being displayed because of the aspect ratio.

 

So, totally satisfied. Thanks again!

Share this post


Link to post
Share on other sites

I didn't download the last "dunexe", but from what I've read here now you can change the music in mid game, reproduce sounds and make a player explode like in the practice mode when the player left, Right?

 

This is something I could use in my Fremen campaign, so your soldiers are not risking his life anymore because of the debris. Or... like in the Red Alert 1 game, when destroying a core building other buildings explode as well.

 

I was thinking:

-How about the possibility to give a player the control of two houses at the same time?

-Or, an event to make 1 "House" joining forces with the human player, like those missions which you start with 10 units and the game tells you to search your base. When you are near that base change to your control.

-Events cheking the healh of a building?  when I said about changing the efficiency of buildings based in their health, you said me a "maybe", so a "if building =50%, enemy reinforcements here".

 

<-- I would say that this is impossible, but maybe you surprise me.

Share this post


Link to post
Share on other sites

This will probably not be working online, I prefer to keep such stuff working online+offline :(

Share this post


Link to post
Share on other sites

in todays games i started having that old bug where you could not place a building again. i think it is because of the fix for the double replacement because of the lag.

Share this post


Link to post
Share on other sites

Yes, I will fix it soon.

 

The bug happens when you right click the grayed out icons in the sidebar, the game will not cancel the production and glitch instead. So make sure you right click on the icon you want to cancel and not on the other icons around it

Share this post


Link to post
Share on other sites

I probably found a bug with music. Your patched Dune2000 plays only one music when playing a mission (the music which plays as first in that mission). That music is still repeating over and over. I tried to play with Vanilla Dune 2000 and everything works there, the game is switching musics.

Could you fix it? Or is it only my problem? It's really annoying to hear just a single drack during whole mission.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×