Jump to content
Sign in to follow this  
Razer

Emperor Installed; Won't Play ("insert correct CD-ROM") :|

Recommended Posts

Hey. Figured this'd be the best place to ask.

 

I've 'acquired' Emperor: Battle for Dune (i.e. its not legit), all four discs, serial number, and it installed just fine, no problems whatsoever. But then when I attempt to play it, a windows message appears: "Please insert the correct CD-ROM, select OK and restart application". I have two DVD drives (DVD Drive D: and DVD RW Drive E:).

 

In my research, I've seen that a few others on the internet have come up with a similar problem, but I haven't found any solutions that worked for me. I tried switching discs, tried placing the first disc in Drive E, but to no avail (though I would assume its because I installed the program in Drive D). I even tried placing the first disc in Drive D, and the second in Drive E (or just a random audio CD in Drive E). Both drives read, rip and burn CDs.

 

Anything you guys can do to help me out? Do I need to install a particular driver or?  Comp was built about four, five years ago but here's its specs:

 

Windows 7 64-bit

Processor: Intel ® Core 2 Quad CPU Q6600 @ 2.40GHz

Installed memory (RAM): 4GB

193GB/465GB free

 

My Dad and I are extremely excited to play this. Please keep in mind that I'm not 100% tech savvy (i.e. can't code, not always sure where to look).

 

Cheers.

Share this post


Link to post
Share on other sites

I've 'acquired' Emperor: Battle for Dune (i.e. its not legit), all four discs, serial number, and it installed just fine, no problems whatsoever. But then when I attempt to play it, a windows message appears: "Please insert the correct CD-ROM, select OK and restart application". I have two DVD drives (DVD Drive D: and DVD RW Drive E:).

This is most probably the cause of your problem: the game is pirated. If you still want to play it, get a no-CD crack and copy all necessary files from the CDs to your HD.

Share this post


Link to post
Share on other sites

i also got non legit copy but still works like butter... well it might be the disc... is there any folder named crack in the iso no 1??(the main disc)... it should be there and paste this in the installed directory... if not find the crack on net... remember version of the game...

Share this post


Link to post
Share on other sites

Even if your version is legal. You still might have a lot of problems. Even the originals might not be read by your pc.

 

I have to install it as if I have windows 98, then I can play it in windows XP. You need 1 of the house cd's for playing.

After updating your version, things might change for the better (old pc's) or for the worse, my case. :(

 

I always have version 1.0 running. Multi player is impossible for me anyway.

Share this post


Link to post
Share on other sites

@Flibble: I may have to do that. This copy was given to me a few years ago by my ex-bf, and I only just found it again. To clarify, would I have to uninstall it and reinstall it before using the no-CD crack (seeing as I already installed stuff/used the serial/etc) or? Dumb question but its better to be safe than sorry.

 

@AQIB: Yeah I see the crack folder now. I copied and pasted it, and it still says the same thing. I went into the Crack folder (both on the disc and what I copied to the directory) and double clicked the Emperor.exe file and it now reads "You must run the game from its install directory"... But I did... *shakes fist* (C: > Program Files (x86) > Westwood).

 

@X3M: I upgraded from XP in August because of rendering issues for animations. I miss XP.

 

Thanks for your help so far by the way :)

Share this post


Link to post
Share on other sites

you sure you copied and pasted it where you installed... well if yes then i guess you need to get another crack...

yea while pasting is it asking for "should it replace old file with new file??" if not it might not work... well if you want i'll give you the crack...

Share this post


Link to post
Share on other sites

Yeah I'm sure, I set the path myself when I installed it instead of letting it do it automatically. It didn't, though, ask if I wanted to replace the crack folder when I copied it the first time -- there was no crack folder where I installed it, only on the disc itself. Wouldn't mind the crack. Where do I paste it?

Share this post


Link to post
Share on other sites

replace the emperor.exe in the game folder... with the crack...

Share this post


Link to post
Share on other sites

That's right, you need to replace the installed game executable with the cracked one from the crack folder, not just copy the folder into your install directory.

Share this post


Link to post
Share on other sites

Well I feel like a giant idiot now :D Its working perfectly. Thanks so much, guys! Much appreciated! <3

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×