Jump to content
ArkAngelMyk

Old problem with Emperor on Windows 7

Recommended Posts

What is the installer called ? And is it publicly avaiable?

It has to be a Nvidia thing as far as Emperor I tried using just one core and 2 megs of ram with the same results.  One question I am wondering is if it is using some form of Open Gl for the graphics.  Windows 7 seems to have big issues with Open Gl, so far I have not been able to run Open Gl on Windows 7 though there is supposed to be a way with OpenGl 3.0

I call it Dune 2000: Grunt Mods Edition, and yes it is. http://dune.gruntmods.com/Dune%202000.msi

As far as I can tell its an Nvidia problem, as using intel integrated graphics solves it. I don`t have an ati card to test my theory out.

Share this post


Link to post
Share on other sites

Thank you for that installer.  Instead of using your integrated graphics for Dune2k I have an alternative solution for you. It seems to work for any of the old games like C&C and Star Craft for some unknown reason.  If you open the screen resolution window and leave it open in the background then start the game it will work normally for some reason.  I tried doing the same with Emperor with no sucess.

Share this post


Link to post
Share on other sites

Thank you for that installer.  Instead of using your integrated graphics for Dune2k I have an alternative solution for you. It seems to work for any of the old games like C&C and Star Craft for some unknown reason.  If you open the screen resolution window and leave it open in the background then start the game it will work normally for some reason.   I tried doing the same with Emperor with no sucess.

well i have 2 computers so its no big deal.

Share this post


Link to post
Share on other sites

I have shut the game down when it hangs and what I have found is that windows is telling me that the graphic driver has quit working. What I am wondering is what changed in the way Nvidia  or windows is handling graphic procedure calls between Vista and 7.  I know that this game worked flawlessly on Vista 64 bit. The only problem was in doing the right tricks to install it.  But ever since the beta for 7 this game has not worked.  If I could find out just what changed then maybe we could find a fix.

Share this post


Link to post
Share on other sites

I have shut the game down when it hangs and what I have found is that windows is telling me that the graphic driver has quit working. What I am wondering is what changed in the way Nvidia  or windows is handling graphic procedure calls between Vista and 7.  I know that this game worked flawlessly on Vista 64 bit. The only problem was in doing the right tricks to install it.  But ever since the beta for 7 this game has not worked.  If I could find out just what changed then maybe we could find a fix.

I really think thats a generic error, just means the drivers  arnt compatible, are you sure you used the SAME drivers? Drivers get updated and sometimes it is at the cost of old games.

Share this post


Link to post
Share on other sites

No I didnt use the same drivers.  What I am saying is that I am wondering what they (either Nvidia or MS) have changed for how they handle things with the drivers. The game works in Vista 64bit.  I have a second computer with updated Vista 64 bit drivers in the house.  The game runs fine on my sons machine.  Unfortunately it is something in either the Windows 7 drivers for Nvidia or Windows 7 itself that has changed that is causing the problem.  Given the problem with the more recent Nvidia drivers causing hardware failure and being pulled offline for download I am wondering if it is more on the Nvidia side.

Share this post


Link to post
Share on other sites

Having the same issue here on win 7 x64.  I also have vm workstation and have built a win xp and win 98 boxes with no luck.  In most cases Dune installation fails stating that the debugger needs to be disabled.  Also used the disk issue/new setup with no luck. Finally gave up and reformatted my laptop that had win 7 and installed win xp.  Installed dune and played with no issues.

Share this post


Link to post
Share on other sites

No I didnt use the same drivers.  What I am saying is that I am wondering what they (either Nvidia or MS) have changed for how they handle things with the drivers. The game works in Vista 64bit.  I have a second computer with updated Vista 64 bit drivers in the house.  The game runs fine on my sons machine.  Unfortunately it is something in either the Windows 7 drivers for Nvidia or Windows 7 itself that has changed that is causing the problem.  Given the problem with the more recent Nvidia drivers causing hardware failure and being pulled offline for download I am wondering if it is more on the Nvidia side.

Thats an issue with the fan control though, which is set manually on most machines anyway.

Share this post


Link to post
Share on other sites

Hello, I'm experiencing the same issue... I use Windows 7 with an Nvidia graphics card...

The problem, must probably is the connection made between Windows 7 and the Nvidia cards.

Just wanted to know if someone has already solved the problem. This is a rare and strange error. However, can someone please show me a way to fix this error? Have you discovered a solution yet?

Cheers

Share this post


Link to post
Share on other sites

Hello, I'm experiencing the same issue... I use Windows 7 with an Nvidia graphics card...

The problem, must probably is the connection made between Windows 7 and the Nvidia cards.

Just wanted to know if someone has already solved the problem. This is a rare and strange error. However, can someone please show me a way to fix this error? Have you discovered a solution yet?

Cheers

nope, try playing with integrated.

Share this post


Link to post
Share on other sites

nope, try playing with integrated.

Sorry, I'm a noob in these things... Can you explain me how to do that or give me a link, please?

Share this post


Link to post
Share on other sites

What gruntlord is suggesting is that you try playing the game using a motherboard with integrated graphics built in instead of using a Nvidia graphics card.    I am still hoping for a solution to the nvidia thing. I do not want to have to pull the graphic card out everytime I wish to play that game. 

Share this post


Link to post
Share on other sites

What gruntlord is suggesting is that you try playing the game using a motherboard with integrated graphics built in instead of using a Nvidia graphics card.     I am still hoping for a solution to the nvidia thing. I do not want to have to pull the graphic card out everytime I wish to play that game.  

Same. Isn't there any option available to disable the Nvidia card and play using the integrated graphics, without having to remove it?

EDIT: Hey guys. It appears that this issue is affecting other somewhat old games... Everybody says it is an Nvidia problem working with Windows 7. Check it here: http://www.pcpuzzle.com/forum/viewtopic.php?p=230345&sid=884a78b79e7f98077f1e455d9ea06c92

Share this post


Link to post
Share on other sites

Found the solution guys. Turn off "Target Lines" in the game options, and the multi-unit select lag will disappear. HAPPY GAMING! :)

Share this post


Link to post
Share on other sites

Found the solution guys. Turn off "Target Lines" in the game options, and the multi-unit select lag will disappear. HAPPY GAMING! :)

It works! Thanks!

Share this post


Link to post
Share on other sites

Couldn't believe my eyes.  Awesome it does indeed work.  Curious as to how you figured that out but many many thanks.

I still get a small stutter every once in a while  but the game is definately working.  I wonder what in the great erg would make the game stall with target lines.

Long live the fighters...

Share this post


Link to post
Share on other sites

Couldn't believe my eyes.  Awesome it does indeed work.  Curious as to how you figured that out but many many thanks.

I still get a small stutter every once in a while  but the game is definately working.  I wonder what in the great erg would make the game stall with target lines.

Long live the fighters...

does it work for the problem where the game wont let you select units with the mouse drag on nvidia cards?

Share this post


Link to post
Share on other sites

Yes I can confirm it does work.  The game now plays fine except for the occasional stutter but it is workable. I was able to go through several single player missions and several rounds of skirmish.

Share this post


Link to post
Share on other sites

I really think that's a generic error, just means the drivers  ant compatible, are you sure you used the SAME drivers? Drivers get updated and sometimes it is at the cost of old games.

Share this post


Link to post
Share on other sites
Same. Isn't there any option available to disable the Nvidia card and play using the integrated graphics, without having to remove it?

a bit late to answer this.

1. Through your BIOS settings.

2. In Windows 9x/XP use hardware profiles to choose between your Graphic Card and integrated one (or both, and change/enable primary display on integrated only when needed to run Emperor!) when OS is loading (I hope same applies in Vista and 7).

Share this post


Link to post
Share on other sites

Just turn off TARGET LINES in the Game Options, and the multi unit select lag will disappear :)

  • Upvote 1

Share this post


Link to post
Share on other sites

@dampkring: um... just a note although you've seen it but this is a 2010 post...

Share this post


Link to post
Share on other sites

yea tht's true... btw this problem is only for x64 comp only ryt??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×